aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2023-07-13 08:36:13 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2023-07-13 08:36:13 +0200
commitcbebdcd20f8c55d1eaf0390088dec68c98b0325c (patch)
treeac1a9ca92cf930006c0937f170c25d26c519aaf9 /games-emulation
parentnet-p2p/dogecoin-qt: unkeyword 1.14.6 for ~x86 (diff)
downloadguru-cbebdcd20f8c55d1eaf0390088dec68c98b0325c.tar.gz
guru-cbebdcd20f8c55d1eaf0390088dec68c98b0325c.tar.bz2
guru-cbebdcd20f8c55d1eaf0390088dec68c98b0325c.zip
games-emulation/yuzu: allow =dev-util/glslang-1.3.250
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yuzu/yuzu-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/games-emulation/yuzu/yuzu-9999.ebuild b/games-emulation/yuzu/yuzu-9999.ebuild
index 3b74ec067..7116a20e0 100644
--- a/games-emulation/yuzu/yuzu-9999.ebuild
+++ b/games-emulation/yuzu/yuzu-9999.ebuild
@@ -48,7 +48,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-cpp/cpp-httplib
dev-cpp/cpp-jwt
- system-vulkan? ( >=dev-util/vulkan-headers-1.3.246
+ system-vulkan? ( >=dev-util/vulkan-headers-1.3.250
dev-util/spirv-headers )
test? ( >dev-cpp/catch-3:0 )
"
@@ -82,6 +82,7 @@ src_unpack() {
fi
git-r3_src_unpack
+
# Do not fetch via sources because this file always changes
use compatibility-list && curl https://api.yuzu-emu.org/gamedb/ > "${S}"/compatibility_list.json
}
@@ -137,12 +138,8 @@ src_prepare() {
fi
# Allow compiling using older glslang
- if use system-vulkan -a has_version '<dev-util/glslang-1.3.246'; then
- sed -i -e '/Vulkan/s/246/236/' CMakeLists.txt || die
- sed -i -e '/VK_ERROR_IMAGE_USAGE_NOT_SUPPORTED_KHR/d;' -e '/VK_ERROR_VIDEO_PICTURE_LAYOUT_NOT_SUPPORTED_KHR/d' \
- -e '/VK_ERROR_VIDEO_PROFILE_OPERATION_NOT_SUPPORTED_KHR/d' -e '/VK_ERROR_VIDEO_PROFILE_FORMAT_NOT_SUPPORTED_KHR/d' \
- -e '/VK_ERROR_VIDEO_PROFILE_CODEC_NOT_SUPPORTED_KHR/d' -e '/VK_ERROR_VIDEO_STD_VERSION_NOT_SUPPORTED_KHR/d' \
- src/video_core/vulkan_common/vulkan_wrapper.cpp
+ if use system-vulkan -a has_version '<dev-util/glslang-1.3.256'; then
+ sed -i '/Vulkan/s/256/250/' CMakeLists.txt
fi
cmake_src_prepare