aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 00:29:27 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 00:30:15 +0900
commitdd0ea0f7210f1e3cde38488554cd1bacc2ba22f6 (patch)
treecc8d44b4e32cc119682942c13fcf5e750e98320a /dev-util
parentapp-admin/pulumi-bin: add 3.127.0, drop 3.121.0 (diff)
downloadguru-dd0ea0f7210f1e3cde38488554cd1bacc2ba22f6.tar.gz
guru-dd0ea0f7210f1e3cde38488554cd1bacc2ba22f6.tar.bz2
guru-dd0ea0f7210f1e3cde38488554cd1bacc2ba22f6.zip
dev-util/ocp-indent: new package, add 1.8.2
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ocp-indent/Manifest1
-rw-r--r--dev-util/ocp-indent/metadata.xml18
-rw-r--r--dev-util/ocp-indent/ocp-indent-1.8.2.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/ocp-indent/Manifest b/dev-util/ocp-indent/Manifest
new file mode 100644
index 000000000..41a1e9038
--- /dev/null
+++ b/dev-util/ocp-indent/Manifest
@@ -0,0 +1 @@
+DIST ocp-indent-1.8.2.tar.gz 109681 BLAKE2B 7d9610bf086a431f39eed9b7314cfe639c2a1a21237c5e5948b8c01b1e84d7036549621e1ab5fb945fd06cd2dbc17b7e9c2a5e3c692b102cbef3e6f859981aec SHA512 c5f8b63d6d3baabbadffba159d485f54f6e903eaa59a58b6df509e12e679b5b63a1cf7734d336d6b3456ea6ac74e42c58889199f2a3ed584566589d0c9bbfef5
diff --git a/dev-util/ocp-indent/metadata.xml b/dev-util/ocp-indent/metadata.xml
new file mode 100644
index 000000000..44bad3916
--- /dev/null
+++ b/dev-util/ocp-indent/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <name>Hiroki Tokunaga</name>
+ </maintainer>
+ <longdescription lang="en">Ocp-indent is based on an approximate, tolerant OCaml parser and a simple stack machine ; this is much faster and more reliable than using regexps. Presets and configuration options available, with the possibility to set them project-wide. Supports most common syntax extensions, and extensible for others.
+
+Includes:
+- An indentor program, callable from the command-line or from within editors
+- Bindings for popular editors
+- A library that can be directly used by editor writers, or just for fault-tolerant/approximate parsing.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/OCamlPro/ocp-indent/issues</bugs-to>
+ <remote-id type="github">OCamlPro/ocp-indent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/ocp-indent/ocp-indent-1.8.2.ebuild b/dev-util/ocp-indent/ocp-indent-1.8.2.ebuild
new file mode 100644
index 000000000..2ffe4a754
--- /dev/null
+++ b/dev-util/ocp-indent/ocp-indent-1.8.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Indentation tool for OCaml, to be used from editors like Emacs and Vim."
+HOMEPAGE="
+ http://www.typerex.org/ocp-indent.html
+ https://github.com/OCamlPro/ocp-indent
+"
+SRC_URI="https://github.com/OCamlPro/ocp-indent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/cmdliner-1.0.0:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"