aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-22 03:34:45 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-22 03:34:45 +0500
commit04323d385f8aff47b46caff766228898b18bfd1e (patch)
treeb23307e3f018eefe2be4d39aa6aa4a43164d0211 /dev-util
parentphosh-base/phosh-osk-stub: add 0.41.1 (diff)
downloadguru-04323d385f8aff47b46caff766228898b18bfd1e.tar.gz
guru-04323d385f8aff47b46caff766228898b18bfd1e.tar.bz2
guru-04323d385f8aff47b46caff766228898b18bfd1e.zip
dev-util/lottieconverter: fix cflags
Closes: https://bugs.gentoo.org/910447 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lottieconverter/files/lottieconverter-0.2-buildtype.patch13
-rw-r--r--dev-util/lottieconverter/lottieconverter-0.2-r2.ebuild (renamed from dev-util/lottieconverter/lottieconverter-0.2.ebuild)26
2 files changed, 31 insertions, 8 deletions
diff --git a/dev-util/lottieconverter/files/lottieconverter-0.2-buildtype.patch b/dev-util/lottieconverter/files/lottieconverter-0.2-buildtype.patch
new file mode 100644
index 000000000..6f77c8d47
--- /dev/null
+++ b/dev-util/lottieconverter/files/lottieconverter-0.2-buildtype.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/910447
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,8 +18,6 @@ add_executable(${PROJECT_NAME})
+
+ if (CMAKE_BUILD_TYPE EQUAL "RELEASE")
+ set(COMPILE_PARAMS ${COMPILE_PARAMS} -O2)
+-else(CMAKE_BUILD_TYPE)
+- set(COMPILE_PARAMS ${COMPILE_PARAMS} -O0 -g3)
+ endif()
+
+ option(SYSTEM_PNG "Use system dynamic libpng" 1)
diff --git a/dev-util/lottieconverter/lottieconverter-0.2.ebuild b/dev-util/lottieconverter/lottieconverter-0.2-r2.ebuild
index 997c31987..dc798c1fc 100644
--- a/dev-util/lottieconverter/lottieconverter-0.2.ebuild
+++ b/dev-util/lottieconverter/lottieconverter-0.2-r2.ebuild
@@ -1,29 +1,39 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
-DESCRIPTION="Simple lottie (telegram animated sticker) converter."
+DESCRIPTION="Simple lottie (telegram animated sticker) converter"
HOMEPAGE="https://github.com/sot-tech/LottieConverter"
SRC_URI="https://github.com/sot-tech/${PN}/archive/refs/tags/r${PV}.tar.gz -> ${P}.tar.gz"
-
-S="${WORKDIR}/LottieConverter-r0.2"
+S="${WORKDIR}/LottieConverter-r${PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
-DEPEND="media-libs/rlottie media-libs/libpng media-libs/giflib"
+DEPEND="
+ media-libs/giflib:=
+ media-libs/libpng:=
+ media-libs/rlottie:=
+ sys-libs/zlib:=
+"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${PN}-0.2-buildtype.patch )
+
src_configure() {
- # -DSYSTEM_PNG=0 -DSYSTEM_RL=1 -DSYSTEM_GL=0
- local mycmakeargs=(-DSYSTEM_PNG=1 -DSYSTEM_RL=1 -DSYSTEM_GL=1)
+ local mycmakeargs=(
+ -DSYSTEM_PNG=ON
+ -DSYSTEM_RL=ON
+ -DSYSTEM_GL=ON
+ )
cmake_src_configure
}
src_install() {
- dobin "${S}_build/lottieconverter"
+ dobin "${BUILD_DIR}"/lottieconverter
+ einstalldocs
}