aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-09-27 02:12:15 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-09-27 02:12:15 +0300
commitacaa9e19e72d68484e08ef2615cdf1f82ad35dde (patch)
treefd1fecc22f146835420eaf941ec5e7298c9e3c8c /dev-util/eclipse-parallel-bin
parentdev-python/keystonemiddleware: unkeyword 9.1.0 (diff)
downloadguru-acaa9e19e72d68484e08ef2615cdf1f82ad35dde.tar.gz
guru-acaa9e19e72d68484e08ef2615cdf1f82ad35dde.tar.bz2
guru-acaa9e19e72d68484e08ef2615cdf1f82ad35dde.zip
dev-util/eclipse-parallel-bin: inherit wrapper,rm eutils. Respect {LD,C}FLAGS
Try to respect LDFLAGS and CFLAGS by updating regular expression Closes: https://bugs.gentoo.org/814977 Closes: https://bugs.gentoo.org/814980 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-util/eclipse-parallel-bin')
-rw-r--r--dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.20.ebuild11
-rw-r--r--dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.21.ebuild4
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.20.ebuild b/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.20.ebuild
index d8106ff52..2d212497f 100644
--- a/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.20.ebuild
+++ b/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.20.ebuild
@@ -3,14 +3,15 @@
EAPI=7
-inherit desktop eutils xdg
+inherit desktop wrapper xdg
MY_PN="eclipse"
+MY_PV="2021-06"
DESCRIPTION="Eclipse IDE for Scientific Computing (C, C++, Fortran)"
HOMEPAGE="https://www.eclipse.org/"
SRC_URI="
- amd64? ( https://download.eclipse.org/technology/epp/downloads/release/2021-06/R/eclipse-parallel-2021-06-R-linux-gtk-x86_64.tar.gz )
- arm64? ( https://download.eclipse.org/technology/epp/downloads/release/2021-06/R/eclipse-parallel-2021-06-R-linux-gtk-aarch64.tar.gz )
+ amd64? ( https://download.eclipse.org/technology/epp/downloads/release/${MY_PV}/R/eclipse-parallel-${MY_PV}-R-linux-gtk-x86_64.tar.gz )
+ arm64? ( https://download.eclipse.org/technology/epp/downloads/release/${MY_PV}/R/eclipse-parallel-${MY_PV}-R-linux-gtk-aarch64.tar.gz )
"
S="${WORKDIR}/${MY_PN}"
@@ -27,7 +28,7 @@ RDEPEND="
QA_FLAGS_IGNORED="
/opt/eclipse-parallel-bin/eclipse
- /opt/eclipse-parallel-bin/plugins/org.eclipse.equinox.launcher.gtk.linux.*/eclipse_*.so
+ /opt/eclipse-parallel-bin/plugins/org.eclipse.equinox.launcher.gtk.linux[.].*/eclipse_.*[.]so
"
src_install() {
@@ -39,5 +40,5 @@ src_install() {
make_wrapper ${PN%-*} "/opt/${PN}/${MY_PN} -vm /opt/openjdk*/bin/java" "" "/opt/${PN}" "/opt/bin"
doicon -s 48 plugins/org.eclipse.platform_4.20.0.v20210611-1600/eclipse48.png
- make_desktop_entry eclipse-parallel "Eclipse IDE Parallel 2021-06" eclipse48 "Development;" || die "Failed making desktop entry!"
+ make_desktop_entry eclipse-parallel "Eclipse IDE Parallel ${MY_PV}" eclipse48 "Development;" || die "Failed making desktop entry!"
}
diff --git a/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.21.ebuild b/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.21.ebuild
index 6dcc00c1c..e42021af5 100644
--- a/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.21.ebuild
+++ b/dev-util/eclipse-parallel-bin/eclipse-parallel-bin-4.21.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop eutils xdg
+inherit desktop wrapper xdg
MY_PN="eclipse"
MY_PV="2021-09"
@@ -28,7 +28,7 @@ RDEPEND="
QA_FLAGS_IGNORED="
/opt/eclipse-parallel-bin/eclipse
- /opt/eclipse-parallel-bin/plugins/org.eclipse.equinox.launcher.gtk.linux.*/eclipse_*.so
+ /opt/eclipse-parallel-bin/plugins/org.eclipse.equinox.launcher.gtk.linux[.].*/eclipse_.*[.]so
"
src_install() {