aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-27 00:07:13 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-27 00:39:06 +0500
commitf5cac009b40982a72d78618dc0f1f56f68660633 (patch)
tree50aa9fbf419a2a2d5f5855c28d5b584a58ca9185 /dev-python
parentnet-im/gtkcord4: Closes https://bugs.gentoo.org/905124 (diff)
downloadguru-f5cac009b40982a72d78618dc0f1f56f68660633.tar.gz
guru-f5cac009b40982a72d78618dc0f1f56f68660633.tar.bz2
guru-f5cac009b40982a72d78618dc0f1f56f68660633.zip
dev-python/pytest-benchmark: enable py3.11
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-benchmark/.maildir/.mu-prop3
-rw-r--r--dev-python/pytest-benchmark/pytest-benchmark-4.0.0.ebuild43
2 files changed, 33 insertions, 13 deletions
diff --git a/dev-python/pytest-benchmark/.maildir/.mu-prop b/dev-python/pytest-benchmark/.maildir/.mu-prop
new file mode 100644
index 000000000..c271d191e
--- /dev/null
+++ b/dev-python/pytest-benchmark/.maildir/.mu-prop
@@ -0,0 +1,3 @@
+uidnext: 1
+version: 3.15
+
diff --git a/dev-python/pytest-benchmark/pytest-benchmark-4.0.0.ebuild b/dev-python/pytest-benchmark/pytest-benchmark-4.0.0.ebuild
index 8cb86fb2d..11891ff60 100644
--- a/dev-python/pytest-benchmark/pytest-benchmark-4.0.0.ebuild
+++ b/dev-python/pytest-benchmark/pytest-benchmark-4.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -24,19 +24,24 @@ RDEPEND="
dev-python/py-cpuinfo[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
"
-BDEPEND="test? (
- dev-python/aspectlib[${PYTHON_USEDEP}]
- dev-python/elasticsearch-py[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/hunter[${PYTHON_USEDEP}]
- dev-python/pygal[${PYTHON_USEDEP}]
- dev-python/pygaljs[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/mercurial
-)" # tests include pytest-xdist integration
+
+# tests include pytest-xdist integration
+BDEPEND="
+ test? (
+ dev-python/aspectlib[${PYTHON_USEDEP}]
+ dev-python/elasticsearch-py[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hunter[${PYTHON_USEDEP}]
+ dev-python/pygal[${PYTHON_USEDEP}]
+ dev-python/pygaljs[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/mercurial
+ )
+"
EPYTEST_DESELECT=(
+ tests/test_benchmark.py::test_help
tests/test_cli.py::test_help
tests/test_cli.py::test_help_compare
)
@@ -45,3 +50,15 @@ distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
+
+python_test() {
+ if [[ ${EPYTHON} == "python3.11" ]]; then
+ # https://github.com/ionelmc/pytest-benchmark/issues/231
+ EPYTEST_DESELECT+=(
+ tests/test_benchmark.py::test_abort_broken
+ "tests/test_utils.py::test_clonefunc[<lambda>]"
+ "tests/test_utils.py::test_clonefunc[f2]"
+ )
+ fi
+ epytest
+}