aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevrin Talen <devrin@fastmail.com>2024-09-13 15:17:50 -0400
committerDevrin Talen <devrin@fastmail.com>2024-09-13 15:52:29 -0400
commite123e951c0e1712a4191c7ae654d8938bf3fb2c5 (patch)
tree6076de9992d85822abd14c0d3612e05c516ae53a /dev-python/xpybutil
parentdev-lang/swift: add missing dev-python/setuptools dependency (diff)
downloadguru-e123e951c0e1712a4191c7ae654d8938bf3fb2c5.tar.gz
guru-e123e951c0e1712a4191c7ae654d8938bf3fb2c5.tar.bz2
guru-e123e951c0e1712a4191c7ae654d8938bf3fb2c5.zip
dev-python/xpybutil: disable py3.8, py3.9
Also added PYTHON_USEDEP to RDEPEND. Signed-off-by: Devrin Talen <devrin@fastmail.com>
Diffstat (limited to 'dev-python/xpybutil')
-rw-r--r--dev-python/xpybutil/xpybutil-0.0.6.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/xpybutil/xpybutil-0.0.6.ebuild b/dev-python/xpybutil/xpybutil-0.0.6.ebuild
index bbc6e48b2..75aae20df 100644
--- a/dev-python/xpybutil/xpybutil-0.0.6.ebuild
+++ b/dev-python/xpybutil/xpybutil-0.0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..13} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="Abstraction layer for xpyb"
@@ -16,6 +16,8 @@ LICENSE="WTFPL"
SLOT="0"
KEYWORDS="~amd64"
+RDEPEND=">=dev-python/xcffib-1.5.0[${PYTHON_USEDEP}]"
+
python_prepare_all() {
sed -i -e "s:share/doc/xpybutil:share/doc/xpybutil-${PV}:" setup.py || die
distutils-r1_python_prepare_all