aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2023-10-05 21:37:35 +0200
committerLucio Sauer <watermanpaint@posteo.net>2023-10-05 21:38:53 +0200
commit6a56accbd6bdc94c6fb84a1d12f58430307548e3 (patch)
tree9ba53e6fcec7ccbae3142af5434e8dfb176f9e07 /dev-python/types-requests
parentnet-news/gfeeds: blueprint-compiler (diff)
downloadguru-6a56accbd6bdc94c6fb84a1d12f58430307548e3.tar.gz
guru-6a56accbd6bdc94c6fb84a1d12f58430307548e3.tar.bz2
guru-6a56accbd6bdc94c6fb84a1d12f58430307548e3.zip
dev-python/types-requests: add 2.31.0.8
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-python/types-requests')
-rw-r--r--dev-python/types-requests/Manifest1
-rw-r--r--dev-python/types-requests/types-requests-2.31.0.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/types-requests/Manifest b/dev-python/types-requests/Manifest
index 7f38906d4..2b29f0885 100644
--- a/dev-python/types-requests/Manifest
+++ b/dev-python/types-requests/Manifest
@@ -1,2 +1,3 @@
DIST types-requests-2.31.0.6.tar.gz 15535 BLAKE2B 165bbedb94cf39b271a32c37e58333d0f59b053a3c882c964e5c46f8fe95fba4ce158434714f4352fc426b6c6fcc98e31caf79407d1778c4e514c0a8a6dfe457 SHA512 e35dc869c6192cea6408407fe024c9dcaeac7baa208df250671f0d99d31e36aa20647d3d1823069bdae27b899d1278010ebfc4ad19ef00a922cd1f64636bd521
DIST types-requests-2.31.0.7.tar.gz 15689 BLAKE2B 98006bfa2da460772ccdd9fe23f25c12a7b1bc6d6cdfe64fb0f0b7114702529cb0caef334cdd91c367c6c0c67dbea32e9b6d2a1c4f757181b9b59f1066e59165 SHA512 57ab649bb0f30d2bfb790eb1e5875779a6fa5708291db2a7e18beac4b436eeb3a19de163095926d907f4e78589082ee677b1e4d68430fd2aa82dbefdaa89666b
+DIST types-requests-2.31.0.8.tar.gz 15960 BLAKE2B 141a6f5594685f6d2c90ee95b55cee78fa862768e201e1a4597c9bbf6a555d4e60ecc61f0120f79db3c8677e78c2e701093605b7bd89cf4d8d34aeece126ed08 SHA512 b551299283fab5761788df032eb5de75041bf9c2f94fff5fc2b679f116714b5b6b197f7a87dc610f8431e8a53994665ca86de735363bfeaa15ca278c2639746d
diff --git a/dev-python/types-requests/types-requests-2.31.0.8.ebuild b/dev-python/types-requests/types-requests-2.31.0.8.ebuild
new file mode 100644
index 000000000..84128ffa2
--- /dev/null
+++ b/dev-python/types-requests/types-requests-2.31.0.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Typing stubs for requests"
+HOMEPAGE="
+ https://pypi.org/project/types-requests/
+ https://github.com/python/typeshed/tree/master/stubs/requests
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+# Depends on _typeshed util stub module bundled with mypy and other type checkers.
+RDEPEND=">=dev-python/urllib3-2"