aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-01-19 01:45:17 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2023-01-19 01:45:17 +0300
commit6fd2bbae37670dca0b5e6ceabc2801bfe3fbc7f7 (patch)
tree74b05953a91f84c7f1af97ac196491ef551a2692 /dev-python/sphinxcontrib-katex
parentdev-python/sphinxcontrib-katex: drop python3.8, fix QA setup.cfg warn (diff)
downloadguru-6fd2bbae37670dca0b5e6ceabc2801bfe3fbc7f7.tar.gz
guru-6fd2bbae37670dca0b5e6ceabc2801bfe3fbc7f7.tar.bz2
guru-6fd2bbae37670dca0b5e6ceabc2801bfe3fbc7f7.zip
dev-python/sphinxcontrib-katex: 0.9.4 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-python/sphinxcontrib-katex')
-rw-r--r--dev-python/sphinxcontrib-katex/Manifest1
-rw-r--r--dev-python/sphinxcontrib-katex/sphinxcontrib-katex-0.9.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-katex/Manifest b/dev-python/sphinxcontrib-katex/Manifest
index 1306eb56b..36a6fe40f 100644
--- a/dev-python/sphinxcontrib-katex/Manifest
+++ b/dev-python/sphinxcontrib-katex/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-katex-0.9.3.tar.gz 98540 BLAKE2B d10e2d00afc178295e1739336b9c8158fb9916c5750e3410e0f23c14cfbb89a3e7c72ea6927712931e21db611137f182a6e87888fbd8279261baf9daabf815c1 SHA512 4d68259dcc00d8f9148b5d8a2ce6a401619d016e2a2fa40c140fd6a2623ac03e0b59cd8c7f263625c3228bdb6e2e5d9b0a7710ff746a70843ba5eba9d9ffda35
+DIST sphinxcontrib-katex-0.9.4.tar.gz 98826 BLAKE2B 8d89ba5b5e282d94f57eb976a8779c176e0ae769eb91cc03d5a44461f51f966be8c995dfc2fc7c74d28d52487a76edd8f64879b6045f5c15d4aa97e2c2eb862f SHA512 3fb66ca12a78d1a22dbb029a1c82de57ff0407da1fba8bf49be927b83c618fe7a80ef5560a1639439a6761146bc3073b4a9e52c6869d44d4d1f05cc311780519
diff --git a/dev-python/sphinxcontrib-katex/sphinxcontrib-katex-0.9.4.ebuild b/dev-python/sphinxcontrib-katex/sphinxcontrib-katex-0.9.4.ebuild
new file mode 100644
index 000000000..64c77dabc
--- /dev/null
+++ b/dev-python/sphinxcontrib-katex/sphinxcontrib-katex-0.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="KaTeX Sphinx extension for rendering of math in HTML pages"
+HOMEPAGE="https://github.com/hagenw/sphinxcontrib-katex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/sphinx-4.5.0-r1[${PYTHON_USEDEP}]"
+
+DOCS=()
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ default
+ sed -i -e 's/license_file/license_files/' setup.cfg || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}