aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStepan Kulikov <stepan_kk@pm.me>2023-03-13 10:09:11 +0300
committerStepan Kulikov <stepan_kk@pm.me>2023-03-13 10:09:11 +0300
commit70633e9620351f23404bc3eed9f8a630efa54c83 (patch)
tree90f1d5b7d6347e1df1f15f58dc183f0499d338af /dev-python/sendgrid
parentapp-misc/clifm: add 1.10, drop 1.6 (diff)
downloadguru-70633e9620351f23404bc3eed9f8a630efa54c83.tar.gz
guru-70633e9620351f23404bc3eed9f8a630efa54c83.tar.bz2
guru-70633e9620351f23404bc3eed9f8a630efa54c83.zip
dev-python/sendgrid: new package
Bug ID - 899732 Added new package - sendgrid and it's dependencies (python-http-client and starkbank-ecdsa) Signed-off-by: Stepan Kulikov <stepan_kk@pm.me>
Diffstat (limited to 'dev-python/sendgrid')
-rw-r--r--dev-python/sendgrid/Manifest1
-rw-r--r--dev-python/sendgrid/metadata.xml12
-rw-r--r--dev-python/sendgrid/sendgrid-6.9.7.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sendgrid/Manifest b/dev-python/sendgrid/Manifest
new file mode 100644
index 000000000..70609ab01
--- /dev/null
+++ b/dev-python/sendgrid/Manifest
@@ -0,0 +1 @@
+DIST sendgrid-6.9.7.tar.gz 49919 BLAKE2B 2fdc245e026d21864d1fd1ea761b88b2597434d9d2287ae2d518802b307d737341c4caed8c2d10d3747482817eeefe5511b8a72a5dfaff6bc31515715fd0ef22 SHA512 861e056c0583bf734b0ccd6c3e940d0bdea621e9f21b6482b72d06721afaa9968290550a9c16b1487c9c0891924731d0d6a152d2dd07070f05800acd2ea5aab8
diff --git a/dev-python/sendgrid/metadata.xml b/dev-python/sendgrid/metadata.xml
new file mode 100644
index 000000000..1d8fa0699
--- /dev/null
+++ b/dev-python/sendgrid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>stepan_kk@pm.me</email>
+ <name>Stepan Kulikov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sendgrid/sendgrid-python</remote-id>
+ <remote-id type="pypi">sendgrid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sendgrid/sendgrid-6.9.7.ebuild b/dev-python/sendgrid/sendgrid-6.9.7.ebuild
new file mode 100644
index 000000000..da0214ef8
--- /dev/null
+++ b/dev-python/sendgrid/sendgrid-6.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Twilio SendGrid library for Python"
+HOMEPAGE="https://github.com/sendgrid/sendgrid-python/ https://pypi.org/project/sendgrid/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS="README.rst"
+
+RDEPEND=">=app-dicts/python-http-client-3.3.5[${PYTHON_USEDEP}]
+ >=app-dicts/starkbank-ecdsa-2.2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}
+
+distutils_enable_tests pytest
+