aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-04 11:57:54 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-05 19:41:33 +0500
commitb83164d8afdfd484a5fb2f8c5818e1de568834d0 (patch)
tree8c8728b5236652430b2eafc133c6ffdee9df6a67 /dev-python/scramp
parentdev-python/asyncmy: new package, add 0.2.5 (diff)
downloadguru-b83164d8afdfd484a5fb2f8c5818e1de568834d0.tar.gz
guru-b83164d8afdfd484a5fb2f8c5818e1de568834d0.tar.bz2
guru-b83164d8afdfd484a5fb2f8c5818e1de568834d0.zip
dev-python/scramp: add 1.4.4
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/scramp')
-rw-r--r--dev-python/scramp/Manifest1
-rw-r--r--dev-python/scramp/scramp-1.4.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/scramp/Manifest b/dev-python/scramp/Manifest
index 6b03a9092..e9a859d77 100644
--- a/dev-python/scramp/Manifest
+++ b/dev-python/scramp/Manifest
@@ -1 +1,2 @@
DIST scramp-1.4.1.tar.gz 30939 BLAKE2B e82edcb4d64ec63a36521742b0526b582860dc31a30410e96108243e51c1dbc3eaf1d7a7a6eec4cca775528a6d80601f1d2e55dbf4ab422d51f0c0bad1195c4d SHA512 47015e0429da1353eb6c89ac89c90ab3e646418af828deb754adc05764cbe2da98a553388a3d3c84320d470b63a66d1882ab96e5a43fd2c2c7e39a82155fb74c
+DIST scramp-1.4.4.tar.gz 21059 BLAKE2B 3577c4447027193bc7a97fc889d7f27271fcdf4491a747a8f1e2b0c560ea66e8228187f2132b51646d9fc3f3d9f48c0b761b1e16c61997eecedb858437430d0e SHA512 60832835ccc3551ef99ee47fc069d4443b4319fa4acb0b3d08eeef434b9358988d9d660ce4fba2ec651d1ea074b3f416bcbeddfa33ab3c91bf26ab325607b874
diff --git a/dev-python/scramp/scramp-1.4.4.ebuild b/dev-python/scramp/scramp-1.4.4.ebuild
new file mode 100644
index 000000000..24e7567e5
--- /dev/null
+++ b/dev-python/scramp/scramp-1.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the SCRAM authentication protocol."
+HOMEPAGE="
+ https://pypi.org/project/scramp/
+ https://github.com/tlocke/scramp
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asn1crypto-1.4.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest