aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-05-07 16:15:55 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-05-07 16:15:55 +0200
commit42285dda639c80ccfbddce47819d70d854e27c58 (patch)
treed21ee0e6109d4706763f7a6c38c2bb4c8799b92b /dev-python/py-nanoid
parentdev-python/mkdocs-blog-plugin: enable py3.12, pypy3 (diff)
downloadguru-42285dda639c80ccfbddce47819d70d854e27c58.tar.gz
guru-42285dda639c80ccfbddce47819d70d854e27c58.tar.bz2
guru-42285dda639c80ccfbddce47819d70d854e27c58.zip
dev-python/py-nanoid: enable py3.12, pypy3
Closes: https://bugs.gentoo.org/931402 Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'dev-python/py-nanoid')
-rw-r--r--dev-python/py-nanoid/py-nanoid-9999.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/py-nanoid/py-nanoid-9999.ebuild b/dev-python/py-nanoid/py-nanoid-9999.ebuild
index 83fd7acbd..6b00fa5da 100644
--- a/dev-python/py-nanoid/py-nanoid-9999.ebuild
+++ b/dev-python/py-nanoid/py-nanoid-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 git-r3
@@ -15,10 +15,4 @@ EGIT_REPO_URI="https://github.com/puyuan/py-nanoid.git"
LICENSE="MIT"
SLOT="0"
-BDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
-"
-DEPEND="${BDEPEND}"
-
distutils_enable_tests pytest