aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-06 23:43:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-07 00:15:38 +0200
commit92c260831f8571fc374f0dad482301e32ce2eed4 (patch)
tree647317bde3d66cf5bbe74f3dafc427babcd667a0 /dev-python/psycopg2cffi
parentdev-python/pyodbc: new package (diff)
downloadguru-92c260831f8571fc374f0dad482301e32ce2eed4.tar.gz
guru-92c260831f8571fc374f0dad482301e32ce2eed4.tar.bz2
guru-92c260831f8571fc374f0dad482301e32ce2eed4.zip
dev-python/psycopg2cffi: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/psycopg2cffi')
-rw-r--r--dev-python/psycopg2cffi/Manifest1
-rw-r--r--dev-python/psycopg2cffi/metadata.xml14
-rw-r--r--dev-python/psycopg2cffi/psycopg2cffi-2.9.0.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/psycopg2cffi/Manifest b/dev-python/psycopg2cffi/Manifest
new file mode 100644
index 000000000..26be24ea9
--- /dev/null
+++ b/dev-python/psycopg2cffi/Manifest
@@ -0,0 +1 @@
+DIST psycopg2cffi-2.9.0.tar.gz 65512 BLAKE2B 2e106eea22feb08aa7154dfc4959a9e68d946b34e872711f19856521dca050d0380498d3c20e762b31e7181ecfc5371a1b02c4bb711bccccfe56a4af9f497ffc SHA512 afd3ce9fa76dcd2df29b7aa8c5d31a33058023dc020ac829b95b8f7950fa17f2733f86a8c45f3d6eefeafae1c7f3997cbae820da98952d71336f7a1c72e84353
diff --git a/dev-python/psycopg2cffi/metadata.xml b/dev-python/psycopg2cffi/metadata.xml
new file mode 100644
index 000000000..1bd6d369b
--- /dev/null
+++ b/dev-python/psycopg2cffi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/chtd/psycopg2cffi/issues</bugs-to>
+ <remote-id type="pypi">psycopg2cffi</remote-id>
+ <remote-id type="github">chtd/psycopg2cffi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/psycopg2cffi/psycopg2cffi-2.9.0.ebuild b/dev-python/psycopg2cffi/psycopg2cffi-2.9.0.ebuild
new file mode 100644
index 000000000..6d228c88d
--- /dev/null
+++ b/dev-python/psycopg2cffi/psycopg2cffi-2.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of the psycopg2 module using cffi. Compatible with Psycopg 2.5."
+HOMEPAGE="
+ https://github.com/chtd/psycopg2cffi
+ https://pypi.org/project/psycopg2cffi
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"