aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-28 10:07:35 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-28 10:46:38 +0500
commitd9b371e10c2b2077b7baf0c53b9fb56e378ed633 (patch)
tree6a54e5c52ef72969e1b5df1ddd0c1ac3b6209811 /dev-python/bidict
parentdev-python/base58: enable py3.11 (diff)
downloadguru-d9b371e10c2b2077b7baf0c53b9fb56e378ed633.tar.gz
guru-d9b371e10c2b2077b7baf0c53b9fb56e378ed633.tar.bz2
guru-d9b371e10c2b2077b7baf0c53b9fb56e378ed633.zip
dev-python/bidict: add 0.22.1
Closes: https://bugs.gentoo.org/884595 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/bidict')
-rw-r--r--dev-python/bidict/Manifest1
-rw-r--r--dev-python/bidict/bidict-0.22.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bidict/Manifest b/dev-python/bidict/Manifest
index a70125f71..9b32625ac 100644
--- a/dev-python/bidict/Manifest
+++ b/dev-python/bidict/Manifest
@@ -1 +1,2 @@
DIST bidict-0.22.0.tar.gz 197969 BLAKE2B 511bea446922c959c7ab2c42fadfe63dc486f9b8f4d060779048195ed02344c36819be917716be6773e2173aa9dbd9e5452e747ee325db6ee92057644789653e SHA512 28384e1f63413023c00c199558eb49298c146602a676226d995aa01ccb0f9a6958750f4e34637d0823d659a092e74bb0ce4d75969d105312f73f5e692d9f82af
+DIST bidict-0.22.1.gh.tar.gz 181134 BLAKE2B aa8606d2d48da1f8a4756bcaf450527c867f67fe284a95299df54b3c711d28d60b869a41d4494f16580c37f197263918bdd9e3d2c6bc347497caa85b4b4dd425 SHA512 c85355125fa0a56c8e763e9c2662be52ca753827d06276adcbe60d87265095e7e59669ec1e4bf3361301a3ae942a9aa47b084f8c3a4a066041d54e353e7b2ea8
diff --git a/dev-python/bidict/bidict-0.22.1.ebuild b/dev-python/bidict/bidict-0.22.1.ebuild
new file mode 100644
index 000000000..36d9abe14
--- /dev/null
+++ b/dev-python/bidict/bidict-0.22.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="The bidirectional mapping library for Python"
+HOMEPAGE="
+ https://pypi.org/project/bidict/
+ https://github.com/jab/bidict
+"
+SRC_URI="https://github.com/jab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ dev-python/sortedcollections[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( {CHANGELOG,README,SECURITY}.rst )
+
+EPYTEST_IGNORE=( tests/test_microbenchmarks.py )
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+src_prepare() {
+ default
+
+ sed -i pytest.ini \
+ -e "/--numprocesses/d" \
+ -e "/--benchmark/d" || die
+}