aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 06:40:02 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 06:59:34 +0500
commit07d089da37e40f6d6da79e7c041a6419146f5c2c (patch)
tree3c955ba94e8581642b0aed2e494ddc3b4c47d925 /dev-python/bidict
parentdev-python/pytest-benchmark: bump EAPI, enable py3.10 (diff)
downloadguru-07d089da37e40f6d6da79e7c041a6419146f5c2c.tar.gz
guru-07d089da37e40f6d6da79e7c041a6419146f5c2c.tar.bz2
guru-07d089da37e40f6d6da79e7c041a6419146f5c2c.zip
dev-python/bidict: bump EAPI, enable py3.10
Also add tests Closes: https://bugs.gentoo.org/807925 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/bidict')
-rw-r--r--dev-python/bidict/bidict-0.21.2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-python/bidict/bidict-0.21.2.ebuild b/dev-python/bidict/bidict-0.21.2.ebuild
index fc5822a57..61ecb2e16 100644
--- a/dev-python/bidict/bidict-0.21.2.ebuild
+++ b/dev-python/bidict/bidict-0.21.2.ebuild
@@ -1,19 +1,27 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="The bidirectional mapping library for Python."
+DESCRIPTION="The bidirectional mapping library for Python"
HOMEPAGE="https://github.com/jab/bidict https://pypi.org/project/bidict/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+KEYWORDS="~amd64 ~x86"
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ dev-python/sortedcollections[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CHANGELOG.rst README.rst SECURITY.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster