aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-15 20:20:10 +0000
committerKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-15 20:20:10 +0000
commit04253f0e73dcaeaf9971f25cd879a58e13bf2590 (patch)
treee1740dc9f3fa3cc10af9f3727b3e5c6a795d9cd7 /dev-python/asyncinotify
parentapp-misc/ledger-live: add 2.53.2, drop 2.50.0 (diff)
downloadguru-04253f0e73dcaeaf9971f25cd879a58e13bf2590.tar.gz
guru-04253f0e73dcaeaf9971f25cd879a58e13bf2590.tar.bz2
guru-04253f0e73dcaeaf9971f25cd879a58e13bf2590.zip
dev-python/asyncinotify: new package, add 4.0.1
Signed-off-by: Kamal Abdellatif <gentoo.kamal@tgf.pw>
Diffstat (limited to 'dev-python/asyncinotify')
-rw-r--r--dev-python/asyncinotify/Manifest1
-rw-r--r--dev-python/asyncinotify/asyncinotify-4.0.1.ebuild26
-rw-r--r--dev-python/asyncinotify/metadata.xml21
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/asyncinotify/Manifest b/dev-python/asyncinotify/Manifest
new file mode 100644
index 000000000..9f6b18b70
--- /dev/null
+++ b/dev-python/asyncinotify/Manifest
@@ -0,0 +1 @@
+DIST asyncinotify-4.0.1.tar.bz2 15598 BLAKE2B 58bbd6743bc857a12045f99c0a740e656edec2f62f2f6475e7ace4c9276bee4b3ae139001efedeff9d916115edfdc932f430c16b4fe989c0cc995843518b8ef6 SHA512 08dda86e57898ec2ee1cfd8831d7e3f3ca963cf9b0a45e9ad690b976ba13d3a0510f7bd4eff6e6030089af4c14da700276ba0573e0eaa5dc23abe9d09c61bcd3
diff --git a/dev-python/asyncinotify/asyncinotify-4.0.1.ebuild b/dev-python/asyncinotify/asyncinotify-4.0.1.ebuild
new file mode 100644
index 000000000..08cd3997a
--- /dev/null
+++ b/dev-python/asyncinotify/asyncinotify-4.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PV="v${PV}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An async python inotify package"
+HOMEPAGE="https://gitlab.com/Taywee/asyncinotify"
+SRC_URI="https://gitlab.com/Taywee/${PN}/-/archive/${MY_PV}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_sphinx docs "dev-python/tomli"
+
+distutils_enable_tests unittest
diff --git a/dev-python/asyncinotify/metadata.xml b/dev-python/asyncinotify/metadata.xml
new file mode 100644
index 000000000..6bfd0e2fb
--- /dev/null
+++ b/dev-python/asyncinotify/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Kamal Abdellatif</name>
+ <email>gentoo.kamal@tgf.pw</email>
+ </maintainer>
+ <longdescription>
+ An async python inotify package. Kept as simple and easy-to-understand as
+ possible, while still being flexible and powerful. This is built on no external
+ dependencies, and works through ctypes in a very obvious fashion.
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">Taywee/asyncinotify</remote-id>
+ <doc>https://asyncinotify.readthedocs.io/en/latest/asyncinotify.html</doc>
+ <maintainer>
+ <name>Taylor C. Richberger</name>
+ <email>tcr@absolute-performance.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>