aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-08 01:09:59 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-08 03:58:07 +0200
commite14b766a03bbb2ba2d25bbed469c80598a507c5c (patch)
tree1df4123c3986be4538a1f6497392f800ad558aa2 /dev-ml
parentsys-power/fan2go: update LICENSE (diff)
downloadguru-e14b766a03bbb2ba2d25bbed469c80598a507c5c.tar.gz
guru-e14b766a03bbb2ba2d25bbed469c80598a507c5c.tar.bz2
guru-e14b766a03bbb2ba2d25bbed469c80598a507c5c.zip
dev-ml/cstruct: add 6.1.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cstruct/Manifest1
-rw-r--r--dev-ml/cstruct/cstruct-6.1.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ml/cstruct/Manifest b/dev-ml/cstruct/Manifest
index 62c35a90c..15faa7e15 100644
--- a/dev-ml/cstruct/Manifest
+++ b/dev-ml/cstruct/Manifest
@@ -1 +1,2 @@
DIST cstruct-6.0.1.tar.gz 243082 BLAKE2B 874ba34583bbc8b53c5b50ba038e2aa423fd704711194dcf99899239015d5fb383242b1d4654c1be2705fd80465e6da7e8eaa5265eceebca7b09dc036d4ebf40 SHA512 2f696b9dca1426d57f60fd4e997ee0c89b1af1a49e186e08c16911ceb03e9f89518a63faf4407b4a7e3c5f391d51979019e47a77f33961624d767a9e36146ca4
+DIST cstruct-6.1.0.tar.gz 242509 BLAKE2B b41eb9b86830b7aef775f9bbfd0f08c29b495a032351ec38dd4553fb944e67a4875b7c2b7175761d78336a20782812148fd473075f4a3519b019f37a2c2ea7dc SHA512 eb1bcb6a35650f726f888c396f3ca64796ad16c1a7146130f8826004c3cac7e5bef2453821ca95844eaef4b4beab25e3db713e6a1a93f86986fb526f75a4e245
diff --git a/dev-ml/cstruct/cstruct-6.1.0.ebuild b/dev-ml/cstruct/cstruct-6.1.0.ebuild
new file mode 100644
index 000000000..8bdc43c77
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="
+ https://github.com/mirage/ocaml-cstruct
+ https://opam.ocaml.org/packages/cstruct/
+"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ocaml-${P}"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async lwt ocamlopt ppx sexp test unix"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=dev-ml/fmt-0.8.9:=
+
+ async? (
+ >=dev-ml/async-0.9.0:=
+ >=dev-ml/async_unix-0.9.0:=
+ >=dev-ml/core-0.9.0:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ >=dev-ml/ppxlib-0.16.0:=
+ dev-ml/stdlib-shims:=
+ )
+ sexp? ( >=dev-ml/sexplib-0.9.0:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/alcotest
+ dev-ml/crowbar
+ >=dev-ml/ocaml-migrate-parsetree-2.1.0
+ dev-ml/ppx_sexp_conv
+ dev-ml/cppo
+ >=dev-ml/lwt-2.0.2
+ )
+"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ppx? ( sexp )
+ test? ( sexp ppx )
+"
+
+src_compile() {
+ local pkgs="cstruct"
+ use ppx && pkgs="${pkgs},ppx_cstruct"
+ for u in async lwt sexp unix ; do
+ if use ${u} ; then
+ pkgs="${pkgs},cstruct-${u}"
+ fi
+ done
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install cstruct
+ use async && dune_src_install cstruct-async
+ use lwt && dune_src_install cstruct-lwt
+ use sexp && dune_src_install cstruct-sexp
+ use unix && dune_src_install cstruct-unix
+ use ppx && dune_src_install ppx_cstruct
+}