aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-01 00:47:36 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-02 03:23:29 +0200
commita90f3f016fb6e7dc559c817200e4a6145556d801 (patch)
tree270da0b77866659c46bcf5b7e3bf0f5629418b8c /dev-ml
parentR-packages.eclass: use edo for all the commands (diff)
downloadguru-a90f3f016fb6e7dc559c817200e4a6145556d801.tar.gz
guru-a90f3f016fb6e7dc559c817200e4a6145556d801.tar.bz2
guru-a90f3f016fb6e7dc559c817200e4a6145556d801.zip
dev-ml/inotify: add 2.4
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/inotify/Manifest1
-rw-r--r--dev-ml/inotify/inotify-2.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/inotify/Manifest b/dev-ml/inotify/Manifest
index 5968c9462..6028fefd5 100644
--- a/dev-ml/inotify/Manifest
+++ b/dev-ml/inotify/Manifest
@@ -1 +1,2 @@
DIST inotify-2.3_p20211118.tar.gz 15870 BLAKE2B cd9b80dcf924ef9fd3c4b95e2e105e17dcfb3b4897b9552ac87b4f8d59dc128f76c6aa95bbf2647b2b60577b53abde003391ba05833ce5ddf0ebbb366b608780 SHA512 3ac6b739797a7d2bafcbe007bd467841eeab8ceecc50dc3a71cd24e0d24da846d9166166a45d6b07d9717d3bab649cd1619ebc8964149700522a7082c1b0d3d5
+DIST inotify-2.4.gh.tar.gz 16439 BLAKE2B 9d96e07b80b594deb3840dd563320de0f53334927e106a4b1e4f9716ad509d97e3cc6003d5386861a4bc00d00031e348a3a32667b4e270dd3aaa2dc46436831f SHA512 d164ab997517008671fdd60ab219cf1539f75928334838f416e31799a2c5198a97eb9d795225c3bb40cc41ac8431022c26b7c8b78ad2d45673158a5e2e554997
diff --git a/dev-ml/inotify/inotify-2.4.ebuild b/dev-ml/inotify/inotify-2.4.ebuild
new file mode 100644
index 000000000..9d9e44111
--- /dev/null
+++ b/dev-ml/inotify/inotify-2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MYPN="ocaml-${PN}"
+
+DESCRIPTION="OCaml bindings for inotify"
+HOMEPAGE="
+ https://github.com/whitequark/ocaml-inotify
+ https://opam.ocaml.org/packages/inotify/
+"
+SRC_URI="https://github.com/whitequark/${MYPN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MYPN}-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-ml/ounit2-2.0
+ >=dev-ml/ocaml-fileutils-0.4.4
+ dev-ml/lwt
+ )
+"
+
+RESTRICT="!test? ( test )"