aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Greener <me@r0bert.dev>2024-04-01 21:25:21 +0100
committerRobert Greener <me@r0bert.dev>2024-04-01 21:34:20 +0100
commit1260137fc600b86098c819641172104c6038e8dd (patch)
tree276b4f9bc66b09a9292ca2f67a33fc852fc35eaa /dev-java
parentdev-java/corretto-bin: new package, version 21.0.2.14.1 (diff)
downloadguru-1260137fc600b86098c819641172104c6038e8dd.tar.gz
guru-1260137fc600b86098c819641172104c6038e8dd.tar.bz2
guru-1260137fc600b86098c819641172104c6038e8dd.zip
dev-java/corretto-bin: new version 17.0.10.8.1
Signed-off-by: Robert Greener <me@r0bert.dev>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/corretto-bin/Manifest1
-rw-r--r--dev-java/corretto-bin/corretto-bin-17.0.10.8.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-java/corretto-bin/Manifest b/dev-java/corretto-bin/Manifest
index 7ac2f1d1d..6c4ef5554 100644
--- a/dev-java/corretto-bin/Manifest
+++ b/dev-java/corretto-bin/Manifest
@@ -1 +1,2 @@
+DIST amazon-corretto-17.0.10.8.1-linux-x64.tar.gz 193714285 BLAKE2B 35184de6bfc2bbc1339817a09aeb1ae31d8eb93aaf4d2e936b69537cedf2dae761fc20ba6895a9344007f1cb50319c821361e0913831c4e0fcb05c06f6b62874 SHA512 485bbf9d6a45aac018ae5af5bac1608f81c91c0cacd6904854b33a0ed52267f55a751e97b4fef7dff37d5cf4300701ef3558b910299f0a85676b54c22b69dce7
DIST amazon-corretto-21.0.2.14.1-linux-x64.tar.gz 209399162 BLAKE2B 8778c7ae7a8588b3a4dd58d5e3c18ca8931b5d4e32c4f308c0f765df7140232d7c800708859d86a66a58275a517edd461c16457159de5ca362d51728559bcd46 SHA512 14264809f297d42163c2c55c827b16eba058c39a36d5e92589419cccf66187b59225b08a8623f556d1febdeedbb2a47975b655b8bd816483d2862c7c44ef0470
diff --git a/dev-java/corretto-bin/corretto-bin-17.0.10.8.1.ebuild b/dev-java/corretto-bin/corretto-bin-17.0.10.8.1.ebuild
new file mode 100644
index 000000000..8305000c2
--- /dev/null
+++ b/dev-java/corretto-bin/corretto-bin-17.0.10.8.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-vm-2 toolchain-funcs
+
+MY_PV=${PV/_p/+}
+SLOT=$(ver_cut 1)
+
+SRC_URI="
+ https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
+"
+
+DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
+HOMEPAGE="https://aws.amazon.com/corretto"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64"
+IUSE="alsa cups headless-awt selinux source"
+
+RDEPEND="
+ >=sys-apps/baselayout-java-0.1.0-r1
+ kernel_linux? (
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz
+ elibc_glibc? ( >=sys-libs/glibc-2.2.5:* )
+ elibc_musl? ( sys-libs/musl )
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )
+ )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
+
+pkg_pretend() {
+ if [[ "$(tc-is-softfloat)" != "no" ]]; then
+ die "These binaries require a hardfloat system."
+ fi
+}
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED}/${dest#/}"
+
+ # prefer system copy # https://bugs.gentoo.org/776676
+ rm -vf lib/libharfbuzz.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+
+ if ! use source ; then
+ rm -v lib/src.zip || die
+ fi
+
+ rm -v lib/security/cacerts || die
+ dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ # provide stable symlink
+ dosym "${P}" "/opt/${PN}-${SLOT}"
+
+ java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+} \ No newline at end of file