aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-07-18 16:29:58 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-07-18 16:34:46 +0200
commita08b91c39bd84c6b76c27d2de47e8db47bc257d5 (patch)
tree65d4e4902257389fc9ff27ee4c992e19ed1365c5 /dev-db
parentdev-db/sqlcmd: add 1.8.0 (diff)
downloadguru-a08b91c39bd84c6b76c27d2de47e8db47bc257d5.tar.gz
guru-a08b91c39bd84c6b76c27d2de47e8db47bc257d5.tar.bz2
guru-a08b91c39bd84c6b76c27d2de47e8db47bc257d5.zip
dev-db/sqlcmd: make DOCS local to avoid variable pollution
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlcmd/sqlcmd-1.7.0.ebuild11
-rw-r--r--dev-db/sqlcmd/sqlcmd-1.8.0.ebuild11
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-db/sqlcmd/sqlcmd-1.7.0.ebuild b/dev-db/sqlcmd/sqlcmd-1.7.0.ebuild
index e4c60d445..ddc5c2180 100644
--- a/dev-db/sqlcmd/sqlcmd-1.7.0.ebuild
+++ b/dev-db/sqlcmd/sqlcmd-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,11 +19,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-DOCS=(
- "README.md"
- "SECURITY.md"
-)
-
src_compile() {
ego build -o "${PN}" -ldflags="-X main.version=${PV}" ./cmd/modern
}
@@ -39,5 +34,9 @@ src_install() {
dofishcomp "completions/${PN}.fish"
dozshcomp "completions/_${PN}"
+ local DOCS=(
+ "README.md"
+ "SECURITY.md"
+ )
einstalldocs
}
diff --git a/dev-db/sqlcmd/sqlcmd-1.8.0.ebuild b/dev-db/sqlcmd/sqlcmd-1.8.0.ebuild
index d6c9071a8..af122c844 100644
--- a/dev-db/sqlcmd/sqlcmd-1.8.0.ebuild
+++ b/dev-db/sqlcmd/sqlcmd-1.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,9 +34,10 @@ src_install() {
dofishcomp "completions/${PN}.fish"
dozshcomp "completions/_${PN}"
-DOCS=(
- "README.md"
- "SECURITY.md"
-)
+ local DOCS=(
+ "README.md"
+ "SECURITY.md"
+ )
+
einstalldocs
}