aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-09-15 13:23:58 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-09-15 13:24:23 +0200
commit7992fd86eff8b5a260df6c1837b4271a75bff548 (patch)
tree22e732fe8bc5c80d756db4265b56953fca6e21ab /dev-db/rum
parentapp-misc/yazi: inherit from xdg eclass to handle .desktop file (diff)
downloadguru-7992fd86eff8b5a260df6c1837b4271a75bff548.tar.gz
guru-7992fd86eff8b5a260df6c1837b4271a75bff548.tar.bz2
guru-7992fd86eff8b5a260df6c1837b4271a75bff548.zip
dev-db/rum: bump compat to pg16, fix multi-target build
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-db/rum')
-rw-r--r--dev-db/rum/rum-1.3.13-r1.ebuild (renamed from dev-db/rum/rum-1.3.13.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-db/rum/rum-1.3.13.ebuild b/dev-db/rum/rum-1.3.13-r1.ebuild
index 132bb2f47..734c3b407 100644
--- a/dev-db/rum/rum-1.3.13.ebuild
+++ b/dev-db/rum/rum-1.3.13-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-POSTGRES_COMPAT=( 9.6 10 11 12 13 14 15 )
+POSTGRES_COMPAT=( 9.6 10 11 12 13 14 15 16 )
POSTGRES_USEDEP="server"
inherit postgres-multi
@@ -22,6 +22,11 @@ RDEPEND="${DEPEND}"
# Needs a running PostgreSQL server
RESTRICT="test"
+src_prepare() {
+ sed -i 's;^PG_CONFIG =;PG_CONFIG ?=;' Makefile || die
+ postgres-multi_src_prepare
+}
+
src_compile() {
postgres-multi_foreach emake USE_PGXS=1
}