aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-29 10:53:53 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-29 12:55:45 +0100
commit1c000f9110e7cdcea88883c6c76324903e64f0c1 (patch)
treec7d75cc63802b78549aa2de67cce2328de14c7ef /dev-cpp/trantor
parent*/*: Remove tastytea as maintainer from gemini packages. (diff)
downloadguru-1c000f9110e7cdcea88883c6c76324903e64f0c1.tar.gz
guru-1c000f9110e7cdcea88883c6c76324903e64f0c1.tar.bz2
guru-1c000f9110e7cdcea88883c6c76324903e64f0c1.zip
dev-cpp/trantor: Version bump 1.5.3.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp/trantor')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 6121d49a9..a816340ed 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,2 +1,3 @@
DIST trantor-1.5.1.tar.gz 102696 BLAKE2B 7670b2e2bb56b703aa387df463433261cff33b5a8682681071ff5159d14a516e11faebde7e2431232ba3651f6420a017491a7468ce3f90c4c099284808e27171 SHA512 9f6664abc94943598805192ee09a98340e6e20efb15e448aac5e21480f1798b0991782d18766f5ef54399251d4980c2f68aeda3136c7e058e3c31623c8f7ce3f
DIST trantor-1.5.2.tar.gz 104534 BLAKE2B d6c5a1d2eff46f5ddcd2d31d3908ee0ac71c96fde097eb3f46ec368f4292604c2dd0689018c9c7272f1a8479d908e6c486776689d517513c6e15b7392e0c7376 SHA512 e5977023c7b435bb7c9041a57e9b4488f34aa977e81709b3f20ae2c56ff6920ef8a4c64813be36705465ef87015c678537e22e349d1408aeb27b33f80eb38f1b
+DIST trantor-1.5.3.tar.gz 104794 BLAKE2B 47cebfc81543d050aa26e9aa0ec2fc9a30311ef25ab750dfe0086a917cc6c5588029b839b6c6205c7a23511f570e9d1dd0cbfdb8ef6a6769ee2d06095862c12a SHA512 2d032c59ad1b57bb1711fe99436fbc8eec5400d91bf310986cb4985e2c2ce1143844701a67241d0fe8dc7ab706b828feded3138aef8cf9d5620e581a1a770079
diff --git a/dev-cpp/trantor/trantor-1.5.3.ebuild b/dev-cpp/trantor/trantor-1.5.3.ebuild
new file mode 100644
index 000000000..ab1fc953c
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="adns doc +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ use ssl || sed -i '/find_package(OpenSSL)/d' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_TRANTOR_SHARED=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_install
+}