aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-03-22 13:45:11 +0100
committerSteffen Winter <steffen.winter@proton.me>2024-03-22 13:45:11 +0100
commitda3ca0d091245b6e4e025529d2e0e89fb5e9abbe (patch)
treec469d8a10c83f369f53a92de93a45ad6d2ed638c /dev-cpp/simdutf
parentgui-apps/swaykbdd: drop 1.0 (diff)
downloadguru-da3ca0d091245b6e4e025529d2e0e89fb5e9abbe.tar.gz
guru-da3ca0d091245b6e4e025529d2e0e89fb5e9abbe.tar.bz2
guru-da3ca0d091245b6e4e025529d2e0e89fb5e9abbe.zip
dev-cpp/simdutf: add 5.0.0
Signed-off-by: Steffen Winter <steffen.winter@proton.me>
Diffstat (limited to 'dev-cpp/simdutf')
-rw-r--r--dev-cpp/simdutf/Manifest1
-rw-r--r--dev-cpp/simdutf/simdutf-5.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/simdutf/Manifest b/dev-cpp/simdutf/Manifest
index 507118cad..59a32d3fb 100644
--- a/dev-cpp/simdutf/Manifest
+++ b/dev-cpp/simdutf/Manifest
@@ -1 +1,2 @@
DIST simdutf-4.0.9.tar.gz 1868141 BLAKE2B 4c326a3c79c38058761e7c8fa39bad2c540a231c52b98cbba9f8e8aa1c691cba86d6d826c8196627ec504088b525c6dce65ae3643b3c4679e170568bc3cfc358 SHA512 39ffc41d8d6889603b72bbcdcb5bce6b0a98cd41299568cf9bd34f5cbc0d5950f96907eae21c0975b10d701c49d80bb839911672909c802e7f6d3b616fe6279c
+DIST simdutf-5.0.0.tar.gz 1923633 BLAKE2B 05ca8b22ca8ed362dc47267b708d7c45d2ad6fbb258808c260ad4e857bce5bbd8a6f176d55da5acd0d8b3fa18f14fee887e087afa94927d1d5a7e9c56567063a SHA512 809ed80e963068191c6fb687f820c9c8e0b638f98d348f65bcf211c4bca1abd3a063adae15cfd7f807a977181f2c0428d61b9183307f5a3ce2ea21e31e6a06d2
diff --git a/dev-cpp/simdutf/simdutf-5.0.0.ebuild b/dev-cpp/simdutf/simdutf-5.0.0.ebuild
new file mode 100644
index 000000000..3875eae9b
--- /dev/null
+++ b/dev-cpp/simdutf/simdutf-5.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="simdutf: Unicode validation and transcoding at billions of characters per second"
+HOMEPAGE="https://simdutf.github.io/simdutf/"
+SRC_URI="https://github.com/simdutf/simdutf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="${PYTHON_DEPS}"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=( -DSIMDUTF_TESTS=$(usex test ON OFF) )
+ cmake_src_configure
+}