aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2023-09-16 23:46:15 +0200
committerAdrian Schollmeyer <nex+b-g-o@nexadn.de>2023-09-16 23:46:15 +0200
commit990e51b9ab285980924bc7722f9d39ad6ed2dde3 (patch)
tree1e1744639949079dac932f81d54a09bc129df775 /dev-cpp/dpp
parentdev-python/mautrix: drop 0.20.0 (diff)
downloadguru-990e51b9ab285980924bc7722f9d39ad6ed2dde3.tar.gz
guru-990e51b9ab285980924bc7722f9d39ad6ed2dde3.tar.bz2
guru-990e51b9ab285980924bc7722f9d39ad6ed2dde3.zip
dev-cpp/dpp: add 10.0.25
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de>
Diffstat (limited to 'dev-cpp/dpp')
-rw-r--r--dev-cpp/dpp/Manifest1
-rw-r--r--dev-cpp/dpp/dpp-10.0.25.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/dpp/Manifest b/dev-cpp/dpp/Manifest
index 9d2026d05..a2a062479 100644
--- a/dev-cpp/dpp/Manifest
+++ b/dev-cpp/dpp/Manifest
@@ -1,2 +1,3 @@
DIST dpp-10.0.23.tar.gz 13721815 BLAKE2B abbe6849025270554f8462dcbef6adefff412ee06216c19a730f236cd44c7e4da1c6b801f2b10a493df253626a4af9b8132aa155c7f585fe3de35eaa5c5cf4df SHA512 18bbb7d2c1385d179cac9ded31d1b11e8d24f172e7ffe2ba79071203e1e2f277657e21d660b18ee4b849bc093d350f4bc5401702400084b56c3ebd6f03ce28df
DIST dpp-10.0.24.tar.gz 13739463 BLAKE2B 0531d9d14b943302293aac62a3972a4628487332107b77ca6d09ae39ae8a9d1cfeceae1a656790cc8699932af9c5d46a0ae5bc26885a9c29cc970388cdb60f3f SHA512 2f1e5415c121d5f19d2abb1b389512ad22c3cac6779ed897403d430b2c4e62c758ab25d46a3fd02538add711073fadd616a690b4981f3782e46c18ff05d116dc
+DIST dpp-10.0.25.tar.gz 14312767 BLAKE2B 52263024ad615198fe901f3cc79290e1b88c4e44c22c318fb7df2e9a3d4069611282b18650602f29f40bff3b042b16d0b8a47b8d3ff9c5b5ea89fa9514777609 SHA512 49cb6fedcb75d3dd146243f46f9e34cfe79e1c9a6ae76fc69c8c6935d9a10ccf562452311085791674ff659913befe1dc6f8a191b518d45151cb23d779396572
diff --git a/dev-cpp/dpp/dpp-10.0.25.ebuild b/dev-cpp/dpp/dpp-10.0.25.ebuild
new file mode 100644
index 000000000..d5cee490c
--- /dev/null
+++ b/dev-cpp/dpp/dpp-10.0.25.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Lightweight C++ Discord bot library"
+HOMEPAGE="https://dpp.dev/ https://github.com/brainboxdotcc/DPP"
+SRC_URI="
+ https://github.com/brainboxdotcc/DPP/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+# DPP is extremely ABI instable due to frequent changes in the Discord API
+# See https://github.com/brainboxdotcc/DPP/issues/207#issuecomment-1007030157
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="voice"
+
+RDEPEND="
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+
+ voice? (
+ dev-libs/libsodium:=
+ media-libs/opus
+ )
+"
+DEPEND="
+ ${RDEPEND}
+
+ dev-cpp/nlohmann_json
+"
+
+S="${WORKDIR}/DPP-${PV}"
+
+DOCS=( "README.md" "SECURITY.md" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=true
+ -DBUILD_VOICE_SUPPORT="$(usex voice)"
+ -DRUN_LDCONFIG=false
+ # Tests require network access
+ -DDPP_BUILD_TEST=false
+ -DDPP_NO_VCPKG=true
+ -DDPP_USE_EXTERNAL_JSON=true
+ )
+
+ cmake_src_configure
+}