aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2025-01-31 11:45:00 +0100
committerDavid Roman <davidroman96@gmail.com>2025-01-31 11:45:00 +0100
commita6f0b1d04e4e31878967db69ee28e9fc58f1472f (patch)
tree46aff417140ed3178a32df9b163862dd49e4cd69 /app-text
parentgui-libs/libsfdo: replace meson_feature with meson_use (diff)
downloadguru-a6f0b1d04e4e31878967db69ee28e9fc58f1472f.tar.gz
guru-a6f0b1d04e4e31878967db69ee28e9fc58f1472f.tar.bz2
guru-a6f0b1d04e4e31878967db69ee28e9fc58f1472f.zip
app-text/lizard: add 1.17.14
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lizard/Manifest1
-rw-r--r--app-text/lizard/lizard-1.17.14.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/lizard/Manifest b/app-text/lizard/Manifest
index 06a1d5833..6a4620b5e 100644
--- a/app-text/lizard/Manifest
+++ b/app-text/lizard/Manifest
@@ -1,2 +1,3 @@
DIST lizard-1.17.10.tar.gz 1230723 BLAKE2B ed6a899088a19c05de7f1a01a0dea23add0ab917a7bf8213bac8417831ad061f0802a742f955ca2dc025e7ad4caf3447ba4f33cd5b020f669dff8aff062f5aa6 SHA512 7b2ebc8ccacec9a72b79f01af76a5574caca28b8d03f28353f29a61cb683cf2fe73e09b7a238f4aa3c487d49aa73b69f040d4040e2d36406c2408d4c1a7d80c3
DIST lizard-1.17.13.tar.gz 1233745 BLAKE2B e41e7bb461f64459f9327fa5719e57cc713dcebb89dfb6b01e27f38a9c6014bbe77b1a50cab094a8b68b630385ca9ff3c35b1a9a65545e9c23942f038b560d33 SHA512 2a81c7033bdda8a4698ae010a5a2c5394a5290008dbc80812063ade1088ac616debb7dd24b4498712979845ed6dee91b728b6ace8c7451f0716707d2caa48c18
+DIST lizard-1.17.14.tar.gz 1238085 BLAKE2B 5261ff0ae39c7d5640ba6aa7074fa8b6315f3650b916c9ca4eb5e5da5cd7e1acba201a949095b6ed049e221af4ac610eb632427c7e39732b8ab0eb0b8737a44b SHA512 db508eb1b0593f4662dd38669939f895f97e385212f0c69547263a6e840ba6bd43c261df15408d7fde15c9b24b139e61a1a53821206144e0ab4dc8bfcb238133
diff --git a/app-text/lizard/lizard-1.17.14.ebuild b/app-text/lizard/lizard-1.17.14.ebuild
new file mode 100644
index 000000000..18a4ff1b5
--- /dev/null
+++ b/app-text/lizard/lizard-1.17.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11,12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A simple code complexity analyser, supports most of the popular languages."
+HOMEPAGE="http://www.lizard.ws/"
+SRC_URI="https://github.com/terryyin/lizard/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest