aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-16 10:54:13 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-16 12:21:04 +0200
commitf29eaa436f24204dbbd44a9464efb5610fee4ed5 (patch)
tree792dd884b2b4a8fc332b1a2e2b38c8c5e21ba234 /app-shells
parentapp-misc/diff-so-fancy: drop 1.4.2, enable tests (diff)
downloadguru-f29eaa436f24204dbbd44a9464efb5610fee4ed5.tar.gz
guru-f29eaa436f24204dbbd44a9464efb5610fee4ed5.tar.bz2
guru-f29eaa436f24204dbbd44a9464efb5610fee4ed5.zip
app-shells/fzf-fish: add 7.3
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf-fish/Manifest1
-rw-r--r--app-shells/fzf-fish/fzf-fish-7.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-shells/fzf-fish/Manifest b/app-shells/fzf-fish/Manifest
index 76e949b55..1a2e4cdb8 100644
--- a/app-shells/fzf-fish/Manifest
+++ b/app-shells/fzf-fish/Manifest
@@ -1 +1,2 @@
DIST fzf-fish-7.1.tar.gz 6068759 BLAKE2B e985e5fdd935e50f079b9e096baad5aaa78478d2dc949c3f813c73b5c728899ad818322adb282f1e0cd4df966014b0cf8bff7e0b66b37958adeecc57564aea3a SHA512 11c89a1ce0fbb9d50370cbb694fb59d0b94847d92ab8333af28493130dce02f55b41df99641d69c6f0503641e891e5ea935ce1e3cb4f095239fd8619ee694e44
+DIST fzf-fish-7.3.tar.gz 5495974 BLAKE2B be1d29e01aae34ea010df44af53658ce0a6b8a58bd885c9e5a3e1e1428d36312f9affbf0a9dc6eac7bca3fe3ae26a67ace343a9a3bc5d22055ef7898eb209b85 SHA512 160735d107f2e6feaf9c51699abe425d36562bfb3a11135564c32944650b76c071fc7d5adc717a0d4f66df43c1ddad9a447d085a3063099dab7a6be1f9c395e7
diff --git a/app-shells/fzf-fish/fzf-fish-7.3.ebuild b/app-shells/fzf-fish/fzf-fish-7.3.ebuild
new file mode 100644
index 000000000..762694654
--- /dev/null
+++ b/app-shells/fzf-fish/fzf-fish-7.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Augment your fish command line with fzf key bindings"
+HOMEPAGE="https://github.com/PatrickF1/fzf.fish"
+SRC_URI="https://github.com/PatrickF1/fzf.fish/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ app-shells/fish
+ app-shells/fzf
+ sys-apps/bat
+ sys-apps/fd
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ app-shells/clownfish
+ app-shells/fishtape
+ app-shells/fzf-fish
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md )
+#RESTRICT="!test? ( test )"
+RESTRICT="test" # how to run tests?
+
+src_install() {
+ insinto "/usr/share/fish/vendor_completions.d"
+ doins completions/*
+ insinto "/usr/share/fish/vendor_conf.d"
+ doins conf.d/*
+ insinto "/usr/share/fish/vendor_functions.d"
+ doins functions/*
+ einstalldocs
+}
+
+src_test() {
+ # it want a git repo
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+
+ fish -c 'fishtape tests/*/*.fish' || die
+}