aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-06 21:07:57 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-06 21:42:50 +0000
commit14040a3e08d1c916d05afb5f853409e1af06e917 (patch)
tree8dae9dae6c9cd54d7dbb483a5a5f2210b8c49b92 /app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild
parentgui-apps/ReGreet: remove old useflags (diff)
downloadguru-14040a3e08d1c916d05afb5f853409e1af06e917.tar.gz
guru-14040a3e08d1c916d05afb5f853409e1af06e917.tar.bz2
guru-14040a3e08d1c916d05afb5f853409e1af06e917.zip
app-shells/zsh-autocomplete: new package, add 23.07.13, 9999
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild')
-rw-r--r--app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild b/app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild
new file mode 100644
index 000000000..42a4d5504
--- /dev/null
+++ b/app-shells/zsh-autocomplete/zsh-autocomplete-23.07.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Real-time type-ahead completion for Zsh."
+HOMEPAGE="https://github.com/marlonrichert/zsh-autocomplete"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marlonrichert/zsh-autocomplete.git"
+else
+ SRC_URI="https://github.com/marlonrichert/zsh-autocomplete/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-5.8"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/${PN}/${PN}.plugin.zsh
+at the end of your ~/.zshrc"
+
+src_install() {
+ # Move repo/tarball folder to zsh "plugin folder"
+ # Remove .git in 9999 (update using portage)
+ [[ ${PV} == 9999 ]] && rm -r "${S}/.git" ||die
+ mkdir -p "${ED}/usr/share/zsh/site-functions/" || die
+ mv "${S}" "${ED}/usr/share/zsh/site-functions/${PN}"
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}