aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-08-01 20:31:28 +0200
committerJonas Frei <freijon@pm.me>2023-08-01 20:32:21 +0200
commit2a67d10bdb2ac57fdf141fe7b8ec7e7f5fc1a94f (patch)
tree5d1ef2934c6e07e009a8f2d55ed58fdccd61df4c /app-office
parentnet-mail/pop: new package, add 0.2.0 (diff)
downloadguru-2a67d10bdb2ac57fdf141fe7b8ec7e7f5fc1a94f.tar.gz
guru-2a67d10bdb2ac57fdf141fe7b8ec7e7f5fc1a94f.tar.bz2
guru-2a67d10bdb2ac57fdf141fe7b8ec7e7f5fc1a94f.zip
app-office/invoice: new package, add 0.1.0
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/invoice/Manifest2
-rw-r--r--app-office/invoice/invoice-0.1.0.ebuild35
-rw-r--r--app-office/invoice/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/app-office/invoice/Manifest b/app-office/invoice/Manifest
new file mode 100644
index 000000000..032644ab4
--- /dev/null
+++ b/app-office/invoice/Manifest
@@ -0,0 +1,2 @@
+DIST invoice-0.1.0-deps.tar.xz 21517072 BLAKE2B 8e351b4aa74994f632ae35d88eb60838a7240551e717fda5657576eba4a1cb6e139870d1830980897d14c12842f54edc49638782f149cafc4f50a8208b5a1aad SHA512 01924501b6d9009027e7ffcf0100149ddaac6dde551a65e9cf150d52c48f0e423ffe29c9d6d232086b4b8e3426580b4342177dec1e9315bf7ddbb63b32cf07c4
+DIST invoice-0.1.0.tar.gz 22300950 BLAKE2B 245d317c82306e70047545b0914e76aa7b69a2e7958387bb0bdbe76d1a77f4e9e873a8a206efec0a0996f614f647c5c918aa871efd301e5b2cfcd4b55b630998 SHA512 534350bcfae7226888295e9227582be5c1a5bb64100f9465af74a991d6406466df9305f1a2fe1f64065bb90b458afe3dc8fb925090032ba22d62c16fe4183696
diff --git a/app-office/invoice/invoice-0.1.0.ebuild b/app-office/invoice/invoice-0.1.0.ebuild
new file mode 100644
index 000000000..f258ceb7d
--- /dev/null
+++ b/app-office/invoice/invoice-0.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Generate invoices from the command line"
+HOMEPAGE="https://github.com/maaslalani/invoice"
+SRC_URI="https://github.com/maaslalani/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Using a dependency tarball as per https://devmanual.gentoo.org/eclass-reference/go-module.eclass/index.html
+DEPS_URI="https://gitlab.com/freijon_gentoo/${CATEGORY}/${PN}/uploads/c7abf25c03f3397186c9deff055a9e89/${P}-deps.tar.xz"
+SRC_URI+=" ${DEPS_URI}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/go
+"
+
+src_compile() {
+ ego build .
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc "README.md"
+ default
+}
diff --git a/app-office/invoice/metadata.xml b/app-office/invoice/metadata.xml
new file mode 100644
index 000000000..978566aa5
--- /dev/null
+++ b/app-office/invoice/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>freijon@pm.me</email>
+ <name>Jonas Frei</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maaslalani/invoice</remote-id>
+ <bugs-to>https://github.com/maaslalani/invoice/issues</bugs-to>
+ </upstream>
+</pkgmetadata>