aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2022-09-16 02:42:26 +0200
committerLucio Sauer <watermanpaint@posteo.net>2022-09-16 02:45:21 +0200
commit666fded28c51537b5d4bc1baa628b6e579cb8165 (patch)
treeaee1563ad949dafff034c0b3f4d7776077d992dc /app-misc
parentprofiles/arch/amd64/x32: add python target for app-misc/anki-bin and mask it ... (diff)
downloadguru-666fded28c51537b5d4bc1baa628b6e579cb8165.tar.gz
guru-666fded28c51537b5d4bc1baa628b6e579cb8165.tar.bz2
guru-666fded28c51537b5d4bc1baa628b6e579cb8165.zip
app-misc/anki-bin: add 2.1.54
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki-bin/Manifest2
-rw-r--r--app-misc/anki-bin/anki-bin-2.1.54.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/anki-bin/Manifest b/app-misc/anki-bin/Manifest
index bbbc8340c..8075610b3 100644
--- a/app-misc/anki-bin/Manifest
+++ b/app-misc/anki-bin/Manifest
@@ -1,3 +1,5 @@
DIST anki-bin-2.1.49.zip 9859031 BLAKE2B efe67559e090fbca990022f0dba9cff5f608ecbdf6d1a38cf682dfe8676458d77dbd0a12f68c19f24a74e8b006c7226c356bd9b03bc9c767ed1c063e3ab749d6 SHA512 cb6d4d65ad63d6a850a4bfd11f91e274f99afefe4eb988da8e72a73e062b3f477ffa5d7e6aac7baa0bb7efd8fafc599c10d36d44e6ab76d8ca2e7ebc83c32c3e
+DIST anki-bin-2.1.54.zip 10987565 BLAKE2B 9ef71f62694f02dab59b7fd54a110df9a3748c373aed52f230dbc2335f881a78e130027559527a6ab1959e21f0337ab13ae89623ae22cf87351133f3cc7aa571 SHA512 d842309251d28218607177140a099f8b190b6f4b9ffb632c33aa0f9423118dd1424e59c70a0c93e57ad08c504cc36650590fda37b107e95bbbfb33521fbca87a
DIST anki.png 34595 BLAKE2B 7b8adeece0d666f819d2e579d04f00102d6a28fe5915b2d13ae0bbf72671f95610d2bb47235509756684d38e4be495b41b6b5814fa0ee2b303adc1c78ed54b88 SHA512 c5051738be8c766629a0ec4cbf95c5f554e7bbca2fb5103b3545f2c34a6fcfd87c1384bbd5239199a8491fa46889b299f5f6e1f23988e271402239cdc2a0a9e7
DIST aqt-2.1.49.zip 2199372 BLAKE2B 319eae4de573bfb07537faa3f3cef18f920dae55c230ce473dc08f5ebf4480df5f7a7d1b875ba7bc3c7147b596288f622db317f7eda835715bd6272e09da64f7 SHA512 65696fb36a5cd0cd9209eee483ffa31b2a9370d90e307140fd1d3ad647c7e6a63d24046dc521704fa78bf15895a0d6e57f72915cd161e1bb03a8bcbecb8099f0
+DIST aqt-2.1.54.zip 5245638 BLAKE2B 29d99cbc27ed07d71351ac3af546d376cf2bf94ce17a4a1e96f78d2cfeb49b8c750f02dc37da44d78ba83dfac41d9d241bf22f45f27fa4a1c4831be3534a9246 SHA512 7f915151a655a020fce5a6bbbe15adc37bfa0aaa33f588e7fb23a25e5ca6842efae6a9465e0b5c3f21ec806794ac723587fde46140a9469b5a7cabec1fc6bd64
diff --git a/app-misc/anki-bin/anki-bin-2.1.54.ebuild b/app-misc/anki-bin/anki-bin-2.1.54.ebuild
new file mode 100644
index 000000000..388a9e9c3
--- /dev/null
+++ b/app-misc/anki-bin/anki-bin-2.1.54.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit python-single-r1 desktop xdg
+
+MY_PN=${PN%-bin}
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="https://apps.ankiweb.net/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/cp39/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}-cp39-abi3-manylinux_2_28_x86_64.whl -> ${P}.zip
+ https://files.pythonhosted.org/packages/py3/a/aqt/aqt-${PV}-py3-none-any.whl -> aqt-${PV}.zip
+ https://raw.githubusercontent.com/ankitects/anki/${PV}/qt/linux/anki.png
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+QA_PREBUILT="usr/lib/*"
+DEPEND="
+$(python_gen_cond_dep '
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/orjson-bin[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/stringcase[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-misc/anki
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+}
+
+src_install() {
+ python_domodule anki
+ python_domodule anki-${PV}.dist-info
+ python_domodule aqt
+ python_domodule aqt-${PV}.dist-info
+ printf "#!/usr/bin/python3\nimport sys;from aqt import run;sys.exit(run())" > runanki
+ python_newscript runanki anki
+ doicon "${DISTDIR}"/anki.png
+ make_desktop_entry /usr/bin/anki Anki anki Education
+}