aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Yang <michaelzcyang@gmail.com>2023-01-07 23:04:56 -0800
committerMichael Yang <michaelzcyang@gmail.com>2023-01-07 23:04:56 -0800
commit69f6e24cd3f59d0aff9029f1c9cba07c9ff9a800 (patch)
tree9f724e4fd179e356204bfa4d2e3a4e6858761d46 /app-misc/clifm
parentdev-nim/jsony: add 1.1.3_p20220114 (diff)
downloadguru-69f6e24cd3f59d0aff9029f1c9cba07c9ff9a800.tar.gz
guru-69f6e24cd3f59d0aff9029f1c9cba07c9ff9a800.tar.bz2
guru-69f6e24cd3f59d0aff9029f1c9cba07c9ff9a800.zip
app-misc/clifm: add 1.8, 1.9
Signed-off-by: Michael Yang <michaelzcyang@gmail.com>
Diffstat (limited to 'app-misc/clifm')
-rw-r--r--app-misc/clifm/Manifest2
-rw-r--r--app-misc/clifm/clifm-1.8.ebuild60
-rw-r--r--app-misc/clifm/clifm-1.9.ebuild60
-rw-r--r--app-misc/clifm/files/clifm-1.8-gentoo-skip-manpage-compression.patch12
-rw-r--r--app-misc/clifm/files/clifm-1.9-gentoo-skip-manpage-compression.patch12
-rw-r--r--app-misc/clifm/files/clifm-9999-gentoo-skip-manpage-compression.patch4
6 files changed, 149 insertions, 1 deletions
diff --git a/app-misc/clifm/Manifest b/app-misc/clifm/Manifest
index 6ff4bc8c7..12627bdee 100644
--- a/app-misc/clifm/Manifest
+++ b/app-misc/clifm/Manifest
@@ -1,2 +1,4 @@
DIST clifm-1.6.tar.gz 1268633 BLAKE2B de36f0d3bc1c6584471d313f346a9db77f659b4fde41775e45c78066db12aff8bf33a58b3c5d0f9cd43800cf823f0508c2abb5c88ff50a28147aec5c7e7178df SHA512 a8f6b73070779d0d49b41109bee1b418cb6eb4fb1ac8e684cf859e1137336df2655ddfb5107b50674a5380364f572fe47cc72f58c25c4ff6439593b411a5f69e
DIST clifm-1.7.tar.gz 1310379 BLAKE2B d37e5f4d013c7a7c8427993aa0ff187bac33cb8a89b75b368ce77eb11cbb3275f5cfabec1037e0b3052471633e763d22a7debe019c75ae6098f44cda0e9f7d70 SHA512 30bdc33090846b82edb2cf6372ca3515806f85261405476518d9b5cb1f9dc22e513263cac70f7d93bb85e6489b1486868964b1719637c1b317ce491b5734c453
+DIST clifm-1.8.tar.gz 1302830 BLAKE2B 87e7dc41053af6ccbd819ec0403ca14aeb40865ea49ab87e8601765be771b5e447f593ffb9f94674dbc2afbdb67849a5a8a1d2b26ab524479c4edbfb2c4c79a6 SHA512 4b534f4c33462dd6571d69a5b0405295580d980f7c5c43f0893828c7ab624eb366f7e617a97b0357a26663df3c25b1cb2c175ee372f8c18e9b3f061186b76827
+DIST clifm-1.9.tar.gz 1331325 BLAKE2B 221f7e3f5a9904a24af6bf31c7ea433e70688ba0cf23e9b6b50478b15f3f16c3b0119e673dfe3991e34ee359d1c6dafeba12c4f9cb1de12255094d1226a6e584 SHA512 03406e2b58accc525bce957a8e27d276503ab63e426cea8023a2835ed4592dabe1f160dcb1502a87851e1afabedb985e634a2c3a0cafa84acdfd29a04f4c3b86
diff --git a/app-misc/clifm/clifm-1.8.ebuild b/app-misc/clifm/clifm-1.8.ebuild
new file mode 100644
index 000000000..d13334589
--- /dev/null
+++ b/app-misc/clifm/clifm-1.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The command line file manager"
+HOMEPAGE="https://github.com/leo-arch/clifm"
+
+inherit optfeature xdg
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/leo-arch/clifm.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/leo-arch/clifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ # also on sourceforge but the unpacked name is irregular
+ # SRC_URI="mirror://sourceforge/${PN}/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo-skip-manpage-compression.patch"
+)
+
+DEPEND="
+ sys-libs/libcap
+ sys-libs/readline:=
+ sys-apps/acl
+ sys-apps/file
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ # makefile defaults to /usr/local
+ emake PREFIX="/usr"
+}
+
+src_install() {
+ # makefile defaults to /usr/local, and manpages to /usr/man
+ emake DESTDIR="${D}" PREFIX="/usr" MANDIR="/usr/share/man" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature_header "Install additional optional functionality:"
+ optfeature "fzf tab completion and more" app-shells/fzf
+ optfeature "mounting/unmounting support" sys-fs/udisks sys-apps/udevil
+ optfeature_header "Install optional archiving support (if you didn't use -D_NO_ARCHIVING):"
+ optfeature "zstd operations" app-arch/zstd
+ optfeature "archive extraction/unpacking" app-arch/atool
+ optfeature "mounting archives" sys-fs/archivemount
+ optfeature "extracting .iso files" app-arch/p7zip
+ optfeature "creating .iso files" app-cdr/cdrtools
+ xdg_pkg_postinst
+}
diff --git a/app-misc/clifm/clifm-1.9.ebuild b/app-misc/clifm/clifm-1.9.ebuild
new file mode 100644
index 000000000..d13334589
--- /dev/null
+++ b/app-misc/clifm/clifm-1.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The command line file manager"
+HOMEPAGE="https://github.com/leo-arch/clifm"
+
+inherit optfeature xdg
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/leo-arch/clifm.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/leo-arch/clifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ # also on sourceforge but the unpacked name is irregular
+ # SRC_URI="mirror://sourceforge/${PN}/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo-skip-manpage-compression.patch"
+)
+
+DEPEND="
+ sys-libs/libcap
+ sys-libs/readline:=
+ sys-apps/acl
+ sys-apps/file
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ # makefile defaults to /usr/local
+ emake PREFIX="/usr"
+}
+
+src_install() {
+ # makefile defaults to /usr/local, and manpages to /usr/man
+ emake DESTDIR="${D}" PREFIX="/usr" MANDIR="/usr/share/man" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature_header "Install additional optional functionality:"
+ optfeature "fzf tab completion and more" app-shells/fzf
+ optfeature "mounting/unmounting support" sys-fs/udisks sys-apps/udevil
+ optfeature_header "Install optional archiving support (if you didn't use -D_NO_ARCHIVING):"
+ optfeature "zstd operations" app-arch/zstd
+ optfeature "archive extraction/unpacking" app-arch/atool
+ optfeature "mounting archives" sys-fs/archivemount
+ optfeature "extracting .iso files" app-arch/p7zip
+ optfeature "creating .iso files" app-cdr/cdrtools
+ xdg_pkg_postinst
+}
diff --git a/app-misc/clifm/files/clifm-1.8-gentoo-skip-manpage-compression.patch b/app-misc/clifm/files/clifm-1.8-gentoo-skip-manpage-compression.patch
new file mode 100644
index 000000000..931001ad8
--- /dev/null
+++ b/app-misc/clifm/files/clifm-1.8-gentoo-skip-manpage-compression.patch
@@ -0,0 +1,12 @@
+Skip manpage compression in makefile.
+
+--- a/Makefile
++++ b/Makefile
+@@ -52,7 +52,6 @@ install: $(BIN)
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DATADIR)/zsh/site-functions
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DESKTOPICONPREFIX)/scalable/apps
+ $(INSTALL) -m 0644 misc/manpage $(DESTDIR)$(MANDIR)/man1/$(BIN).1
+- gzip -f -- $(DESTDIR)$(MANDIR)/man1/$(BIN).1
+ $(INSTALL) -m 0644 misc/completions.bash $(DESTDIR)$(DATADIR)/bash-completion/completions/$(BIN)
+ $(INSTALL) -m 0644 misc/completions.zsh $(DESTDIR)$(DATADIR)/zsh/site-functions/_$(BIN)
+ $(INSTALL) -m 0644 misc/$(BIN).desktop $(DESTDIR)$(DESKTOPPREFIX)
diff --git a/app-misc/clifm/files/clifm-1.9-gentoo-skip-manpage-compression.patch b/app-misc/clifm/files/clifm-1.9-gentoo-skip-manpage-compression.patch
new file mode 100644
index 000000000..20406d986
--- /dev/null
+++ b/app-misc/clifm/files/clifm-1.9-gentoo-skip-manpage-compression.patch
@@ -0,0 +1,12 @@
+Skip manpage compression in makefile.
+
+--- a/Makefile
++++ b/Makefile
+@@ -53,7 +53,6 @@ install: $(BIN)
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DATADIR)/zsh/site-functions
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DESKTOPICONPREFIX)/scalable/apps
+ $(INSTALL) -m 0644 misc/manpage $(DESTDIR)$(MANDIR)/man1/$(BIN).1
+- gzip -f -- $(DESTDIR)$(MANDIR)/man1/$(BIN).1
+ $(INSTALL) -m 0644 misc/completions.bash $(DESTDIR)$(DATADIR)/bash-completion/completions/$(BIN)
+ $(INSTALL) -m 0644 misc/completions.zsh $(DESTDIR)$(DATADIR)/zsh/site-functions/_$(BIN)
+ $(INSTALL) -m 0644 misc/$(BIN).desktop $(DESTDIR)$(DESKTOPPREFIX)
diff --git a/app-misc/clifm/files/clifm-9999-gentoo-skip-manpage-compression.patch b/app-misc/clifm/files/clifm-9999-gentoo-skip-manpage-compression.patch
index 9201488ff..20406d986 100644
--- a/app-misc/clifm/files/clifm-9999-gentoo-skip-manpage-compression.patch
+++ b/app-misc/clifm/files/clifm-9999-gentoo-skip-manpage-compression.patch
@@ -1,6 +1,8 @@
+Skip manpage compression in makefile.
+
--- a/Makefile
+++ b/Makefile
-@@ -51,7 +51,6 @@ install: $(BIN)
+@@ -53,7 +53,6 @@ install: $(BIN)
$(INSTALL) -m 0755 -d $(DESTDIR)$(DATADIR)/zsh/site-functions
$(INSTALL) -m 0755 -d $(DESTDIR)$(DESKTOPICONPREFIX)/scalable/apps
$(INSTALL) -m 0644 misc/manpage $(DESTDIR)$(MANDIR)/man1/$(BIN).1