aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-04-07 14:56:12 +0200
committertastytea <gentoo@tastytea.de>2023-04-07 14:58:29 +0200
commit4a979a9ad851cca9e8ff470265b927d2c5ef18c2 (patch)
treea728ba3a4fbb93b5a779dd1d0404c794680266f9 /app-editors
parentdev-embedded/rauc: drop 1.8 (diff)
downloadguru-4a979a9ad851cca9e8ff470265b927d2c5ef18c2.tar.gz
guru-4a979a9ad851cca9e8ff470265b927d2c5ef18c2.tar.bz2
guru-4a979a9ad851cca9e8ff470265b927d2c5ef18c2.zip
app-editors/neovim-qt: support >=dev-libs/msgpack-6
Closes: https://bugs.gentoo.org/903963 Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim-qt/files/neovim-qt-0.2.17-fix-finding-msgpack-6+.patch26
-rw-r--r--app-editors/neovim-qt/neovim-qt-0.2.17-r1.ebuild (renamed from app-editors/neovim-qt/neovim-qt-0.2.17.ebuild)5
2 files changed, 29 insertions, 2 deletions
diff --git a/app-editors/neovim-qt/files/neovim-qt-0.2.17-fix-finding-msgpack-6+.patch b/app-editors/neovim-qt/files/neovim-qt-0.2.17-fix-finding-msgpack-6+.patch
new file mode 100644
index 000000000..85e532f41
--- /dev/null
+++ b/app-editors/neovim-qt/files/neovim-qt-0.2.17-fix-finding-msgpack-6+.patch
@@ -0,0 +1,26 @@
+# upstream commit: https://github.com/equalsraf/neovim-qt/commit/c6ae970
+
+From c6ae9709237b6a55a705687afe4103646f34ac60 Mon Sep 17 00:00:00 2001
+From: Carlo Cabrera <30379873+carlocab@users.noreply.github.com>
+Date: Sun, 5 Mar 2023 23:03:47 +0800
+Subject: [PATCH] Fix finding msgpack 6+
+
+`libmsgpackc` was renamed to `libmsgpack-c` in 6.0.0. See
+msgpack/msgpack-c#1053.
+---
+ cmake/FindMsgpack.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/FindMsgpack.cmake b/cmake/FindMsgpack.cmake
+index 0e2013f9d..41e2d7b5c 100644
+--- a/cmake/FindMsgpack.cmake
++++ b/cmake/FindMsgpack.cmake
+@@ -5,7 +5,7 @@ find_path(MSGPACK_INCLUDE_DIR
+ )
+
+ find_library(MSGPACK_LIBRARY
+- NAMES msgpack msgpackc libmsgpack.a libmsgpackc.a
++ NAMES msgpack-c msgpack msgpackc libmsgpack.a libmsgpackc.a
+ )
+
+ mark_as_advanced(MSGPACK_INCLUDE_DIR MSGPACK_LIBRARY)
diff --git a/app-editors/neovim-qt/neovim-qt-0.2.17.ebuild b/app-editors/neovim-qt/neovim-qt-0.2.17-r1.ebuild
index 238a8e04f..a1a758b5c 100644
--- a/app-editors/neovim-qt/neovim-qt-0.2.17.ebuild
+++ b/app-editors/neovim-qt/neovim-qt-0.2.17-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,7 +38,8 @@ RDEPEND="
RESTRICT="!test? ( test )"
PATCHES=(
- "${FILESDIR}"/${PN}-0.2.17-only-require-Qt5Test-if-tests-are-enabled.patch
+ "${FILESDIR}"/${P}-only-require-Qt5Test-if-tests-are-enabled.patch
+ "${FILESDIR}"/${P}-fix-finding-msgpack-6+.patch
)
src_configure() {
local mycmakeargs=(