aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-11-06 20:46:42 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2023-11-06 20:46:42 +0100
commit41b59b9c05180d9b2d58ee184b7d141aaaab6caa (patch)
treec5d06c2b3a60757c23c0763af069e74ffe4614c3 /app-editors
parentnet-misc/tuba: Add gstreamer dependency (diff)
downloadguru-41b59b9c05180d9b2d58ee184b7d141aaaab6caa.tar.gz
guru-41b59b9c05180d9b2d58ee184b7d141aaaab6caa.tar.bz2
guru-41b59b9c05180d9b2d58ee184b7d141aaaab6caa.zip
app-editors/lapce: fix build of nightly when on stable version
Closes: https://bugs.gentoo.org/909102 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/lapce/lapce-0.3.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-editors/lapce/lapce-0.3.0-r1.ebuild b/app-editors/lapce/lapce-0.3.0-r1.ebuild
new file mode 100644
index 000000000..423cbd376
--- /dev/null
+++ b/app-editors/lapce/lapce-0.3.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+CRATES=" "
+
+inherit cargo desktop xdg-utils
+
+DESCRIPTION="Lightning-fast and Powerful Code Editor written in Rust "
+HOMEPAGE="https://lapce.dev/"
+SRC_URI="
+ https://github.com/lapce/lapce/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/lapce/lapce/releases/download/v${PV}/vendor.tar.gz -> ${P}-vendor.tar.gz
+"
+
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions Artistic-2 BSD BSD-2 Boost-1.0 CC0-1.0 CeCILL-2.1 GPL-2 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ x11-libs/gtk+:3
+ media-libs/fontconfig
+ sys-libs/zlib
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/cmake
+ sys-devel/gcc
+ virtual/pkgconfig
+ >=virtual/rust-1.64
+"
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_unpack() {
+ default
+ cargo_gen_config
+ ln -s "${WORKDIR}/vendor/" "${WORKDIR}/lapce-${PV}/vendor" || die
+ sed -i "${ECARGO_HOME}/config" -e '/source.crates-io/d' || die
+ sed -i "${ECARGO_HOME}/config" -e '/replace-with = "gentoo"/d' || die
+ sed -i "${ECARGO_HOME}/config" -e '/local-registry = "\/nonexistent"/d' || die
+ cat "${WORKDIR}/vendor/vendor-config.toml" >> "${ECARGO_HOME}/config" || die
+}
+
+src_compile() {
+ export RELEASE_TAG_NAME=v0.3.0
+ cargo_src_compile
+}
+
+src_install() {
+ dobin target/release/lapce
+ dobin target/release/lapce-proxy
+ domenu extra/linux/dev.lapce.lapce.desktop
+ newicon extra/images/logo.png dev.lapce.lapce.png
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}