aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiFei Zhu <zhuyifei1999@gmail.com>2023-06-15 23:37:02 -0700
committerYiFei Zhu <zhuyifei1999@gmail.com>2023-06-15 23:39:03 -0700
commit0789691e9de600e6c2a6d604ecd0a93e56e1d998 (patch)
tree54f458f7220ac938a0001f840eea948bb6dd069a /app-editors
parentgames-emulation/RetroArch: change dep from pulseaudio to libpulse (diff)
downloadguru-0789691e9de600e6c2a6d604ecd0a93e56e1d998.tar.gz
guru-0789691e9de600e6c2a6d604ecd0a93e56e1d998.tar.bz2
guru-0789691e9de600e6c2a6d604ecd0a93e56e1d998.zip
app-editors/pulsar-bin: add 1.106.0
Signed-off-by: YiFei Zhu <zhuyifei1999@gmail.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/pulsar-bin/Manifest1
-rw-r--r--app-editors/pulsar-bin/pulsar-bin-1.106.0.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/app-editors/pulsar-bin/Manifest b/app-editors/pulsar-bin/Manifest
index c4c1d31ad..21689b2f5 100644
--- a/app-editors/pulsar-bin/Manifest
+++ b/app-editors/pulsar-bin/Manifest
@@ -1,2 +1,3 @@
DIST pulsar-bin-1.105.0-amd64.tar.gz 228995179 BLAKE2B b4b185a161374590b68e2efbd5b2f37ec59278f71cc30ef519c3a67ae546ea9b73f2e2e50eabd8b07855e291704f4d994428f58dca24e144713e4996fe053b03 SHA512 f2ed05bebe81735c21ac80ff82ec051aebc9ec54e8f2ffce0e4e17f0fc6b221992ca5909271f04334211e494647cfef9f1555f0f439ee77c63488585f255f810
DIST pulsar-bin-1.105.0-arm64.tar.gz 190376758 BLAKE2B 4901f01497f7a015f95f77126f91f7817ffa8bd82d10066f741dd53dd67ec6f43bec1f7a34d949f00f2efed9f36b0f19745fb71abbc6074ca248f08d4159062a SHA512 e201118befcc14308f1383309fd0a7a258f72d1aa31b59da8ffb863ab9a43b821b5285dfe4fde1ccdf8f92121c1898b8022f604362e7415dcf7d8fc05d8de512
+DIST pulsar-bin-1.106.0-amd64.tar.gz 230175989 BLAKE2B c26238659ec32918b06563aa14462d2a47f87612d18d0e309ebdeaafb8282c5c2f839264eda7cc3151bb9643b783ac47e0e008eccf59fb8347d7b71995137da5 SHA512 9ce4e1ba0ca375a035863ca955592ebde9e20c16aa06d6ab3bd803d32edbd35d916b5ef94c2072f21f3d9a60546798fa2aaa74608299101713e92cce367fd0f6
diff --git a/app-editors/pulsar-bin/pulsar-bin-1.106.0.ebuild b/app-editors/pulsar-bin/pulsar-bin-1.106.0.ebuild
new file mode 100644
index 000000000..11df6e3d3
--- /dev/null
+++ b/app-editors/pulsar-bin/pulsar-bin-1.106.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A Community-led Hyper-Hackable Text Editor"
+HOMEPAGE="https://pulsar-edit.dev/"
+
+# ARM64 build is missing upstream for 1.106.0
+# arm64? ( https://github.com/pulsar-edit/pulsar/releases/download/v${PV}/ARM.Linux.pulsar-${PV}-arm64.tar.gz -> ${P}-arm64.tar.gz )
+SRC_URI="
+ amd64? ( https://github.com/pulsar-edit/pulsar/releases/download/v${PV}/Linux.pulsar-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="test"
+
+S="${WORKDIR}/pulsar-${PV}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ app-crypt/libsecret
+ dev-libs/nss
+ dev-libs/openssl
+ dev-libs/openssl-compat
+ dev-vcs/git
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Pulsar/*"
+QA_PRESTRIPPED="/opt/Pulsar/resources/*" # Files are already stripped
+
+src_unpack(){
+ default
+
+ if use arm64; then
+ mv "pulsar-${PV}-arm64" "pulsar-${PV}" || die
+ fi
+}
+
+src_prepare(){
+ default
+
+ # We do not install licenses
+ rm resources/LICENSE.md || die "Failed to remove LICENSE"
+}
+
+src_install(){
+ dodir /opt/Pulsar
+ mv "${S}"/* "${ED}"/opt/Pulsar
+
+ dosym ../../opt/Pulsar/resources/pulsar.sh /usr/bin/pulsar
+
+ # Bug #906939
+ if use amd64; then
+ rm "${ED}"/opt/Pulsar/resources/app.asar.unpacked/node_modules/tree-sitter-bash/build/node_gyp_bins/python3
+ rmdir "${ED}"/opt/Pulsar/resources/app.asar.unpacked/node_modules/tree-sitter-bash/build/node_gyp_bins
+ fi
+
+ doicon "${ED}"/opt/Pulsar/resources/pulsar.png
+ make_desktop_entry "/usr/bin/pulsar %F" "Pulsar" "pulsar" \
+ "GNOME;GTK;Utility;TextEditor;Development;" \
+ "GenericName=Text Editor\nStartupNotify=true\nStartupWMClass=pulsar\n" \
+ "MimeType=application/javascript;application/json;application/x-httpd-eruby;" \
+ "application/x-httpd-php;application/x-httpd-php3;application/x-httpd-php4;" \
+ "application/x-httpd-php5;application/x-ruby;application/x-bash;application/x-csh;" \
+ "application/x-sh;application/x-zsh;application/x-shellscript;application/x-sql;" \
+ "application/x-tcl;application/xhtml+xml;application/xml;application/xml-dtd;" \
+ "application/xslt+xml;text/coffeescript;text/css;text/html;text/plain;text/xml;" \
+ "text/xml-dtd;text/x-bash;text/x-c++;text/x-c++hdr;text/x-c++src;text/x-c;text/x-chdr;" \
+ "text/x-csh;text/x-csrc;text/x-dsrc;text/x-diff;text/x-go;text/x-java;text/x-java-source;" \
+ "text/x-makefile;text/x-markdown;text/x-objc;text/x-perl;text/x-php;text/x-python;" \
+ "text/x-ruby;text/x-sh;text/x-zsh;text/yaml;inode/directory"
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst(){
+ xdg_desktop_database_update
+
+ elog "To migrate configurations & saved state from Atom Editor, execute:"
+ elog " cp -a \$HOME/.atom \$HOME/.pulsar"
+ elog " cp -a \$HOME/.config/Atom \$HOME/.config/Pulsar"
+}