aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-11 03:47:42 +0530
committerRahil Bhimjiani <me@rahil.rocks>2024-03-11 03:48:10 +0530
commit8e472f44c79ef8f1b4fb211d03afa35012f3e0ca (patch)
treed4ec80488f9ba850df473bb7e03bd724ddc36470 /app-crypt
parentapp-admin/himitsu-keyring: enable py3.12 (diff)
downloadguru-8e472f44c79ef8f1b4fb211d03afa35012f3e0ca.tar.gz
guru-8e472f44c79ef8f1b4fb211d03afa35012f3e0ca.tar.bz2
guru-8e472f44c79ef8f1b4fb211d03afa35012f3e0ca.zip
app-crypt/lego: add 4.16.0
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/lego/Manifest3
-rw-r--r--app-crypt/lego/lego-4.16.0.ebuild82
-rw-r--r--app-crypt/lego/lego-9999.ebuild2
3 files changed, 86 insertions, 1 deletions
diff --git a/app-crypt/lego/Manifest b/app-crypt/lego/Manifest
index a56340a1d..3d4c7d79e 100644
--- a/app-crypt/lego/Manifest
+++ b/app-crypt/lego/Manifest
@@ -4,3 +4,6 @@ DIST lego-4.14.2.tar.gz 672197 BLAKE2B b633d6ed12fd7d38c35db392a58785fd32c347596
DIST lego-4.15.0-deps.tar.xz 211464468 BLAKE2B 545c8029f4bd337a73d9ba68b7c07e9c38a67e2ab35db31b3c79d3b438f4db88317be4715bcc642e41cb29d920e9dcbb0c9de75a1ecf14fff08f14b1056a43b8 SHA512 551532265fa0f42530ef428f798e293bc96530ad307b4bd658c77e4ca74fd8323766868b8b75e5657aa0f5f627705b3f1990430042cb7a8338269d7234179039
DIST lego-4.15.0-docs.tar.gz 3650516 BLAKE2B b08d587ec1ee9dad15c568ab979270cf112ba8cf29c1eabd818f30bf38dd29c0625df1fff7d54ce1ed87dfe191378ad0ec288a11d3f029d55c1593c50301061a SHA512 34b1172aa9e4ef53cd2efb1e84ab0b94de2280f81440477471ebf0091cad2996ae0dbef9797b7f652c6ec13053eb6557cd809dbd48b1936747d3c0e4eda63a3d
DIST lego-4.15.0.tar.gz 683931 BLAKE2B b4bcdca4ea72e7826b690b15c297b37c186567d0167715542279acad6173d8e77883ffb79ab9cdb53f505421f67326ceca52a698f9a977cffc738b77dd8d29ed SHA512 a6cc56cbd430ed4b05451783c81d95bbd16e1c4874078b96a9057e2e7b3fde581be1b3663fdc7713079df7f2f24c8581b2f6af5b6c64737303f98e7e2bde8602
+DIST lego-4.16.0-deps.tar.xz 211637812 BLAKE2B ce3089dd2f355a72e6cf81309ae389a01eb65ce832e38065174997636b9b62e742ef7cddb3aa5ab9a8657b2d643b0e190b8f75fc9b767d74fcebb71e0d860146 SHA512 62fd86bef1163c5b0f8a3a3540e7fe94ccee1b097449c42f0d5267894a4e0931a89c0f8e2e2af0f37757c7a4f25fe0d27a305aa51490b7f522ec23b9267b7eb9
+DIST lego-4.16.0-docs.tar.gz 3681408 BLAKE2B 3be8f0a8d9aaa13e4ff3bf0bd8b928bc7be0e1bec0dd31cc5e91cd1ae7d19a6952fe81a3db5c89d296642325b897e436acacf1e18975fdf5cbe34d0b1e1e7371 SHA512 80819d4496cd2cabf1d9eb8f254b240edf43e01a01c2de28274799986bee7f9a8698fc8dbba000d8e4e37b2d68e4a9f772214a237321077dedbe3a0657666244
+DIST lego-4.16.0.tar.gz 698821 BLAKE2B 9058f856a477c70c12352df4786e18dadf444df60ed462411367a8aa18ce1e98ede4358e6aad8032d5d3230341fd7e544343bda27fd92c46c494e0a5eb683f35 SHA512 ba40fdcd94cb1f12d609104d1af5c8e398f3a3d70e4d2a0b65365b401b6928149749778de9acb138e9548d634ea210641c07d2218135f2e4c903a39947f206e5
diff --git a/app-crypt/lego/lego-4.16.0.ebuild b/app-crypt/lego/lego-4.16.0.ebuild
new file mode 100644
index 000000000..3c984d15f
--- /dev/null
+++ b/app-crypt/lego/lego-4.16.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Let's Encrypt/ACME client (like certbot or acme.sh) and library written in Go"
+HOMEPAGE="https://github.com/go-acme/lego/"
+
+DOCUMENTATION_COMMIT=1f91ea806ff8f3184b7f4e00fc6e69b1e23a08a2
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/go-acme/lego.git"
+else
+ SRC_URI="
+ https://github.com/go-acme/lego/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz
+ doc? ( https://github.com/go-acme/lego/archive/${DOCUMENTATION_COMMIT}.tar.gz -> ${P}-docs.tar.gz )
+"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# main
+LICENSE="MIT"
+# deps
+LICENSE+=" Apache-2.0 BSD-2 BSD ISC MPL-2.0"
+SLOT="0"
+IUSE="doc"
+
+# some tests require network access otherwise get following error
+# expected: "zoneee: unexpected status code: [status code: 401] body: Unauthorized"
+# actual : "zoneee: could not find zone for domain \"prefix.example.com\" (_acme-challenge.prefix.example.com.): could not find the start of authority for _acme-challenge.prefix.example.com.: read udp 10.0.0.1:54729->10.0.0.1:53: read: connection refused"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ if use doc; then
+ EGIT_BRANCH="gh-pages"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}-doc"
+ git-r3_src_unpack
+ fi
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ export CGO_ENABLED=0
+
+ local VERSION
+ if [[ ${PV} == 9999* ]]; then
+ VERSION="$(git rev-parse HEAD)" || die
+ else
+ VERSION="${PV}"
+ fi
+
+ ego build -trimpath -ldflags "-X main.version=${VERSION}" -o dist/"${PN}" ./cmd/lego/
+}
+
+src_test() {
+ ego test -v -cover ./...
+}
+
+src_install() {
+ # primary program
+ dobin dist/"${PN}"
+
+ # docs
+ einstalldocs
+ if use doc; then
+ if [[ ${PV} == 9999* ]]; then
+ dodoc -r ../"${P}"-doc/*
+ else
+ dodoc -r ../"${PN}"-"${DOCUMENTATION_COMMIT}"/*
+ fi
+ fi
+}
diff --git a/app-crypt/lego/lego-9999.ebuild b/app-crypt/lego/lego-9999.ebuild
index 283540e19..3c984d15f 100644
--- a/app-crypt/lego/lego-9999.ebuild
+++ b/app-crypt/lego/lego-9999.ebuild
@@ -8,7 +8,7 @@ inherit go-module
DESCRIPTION="Let's Encrypt/ACME client (like certbot or acme.sh) and library written in Go"
HOMEPAGE="https://github.com/go-acme/lego/"
-DOCUMENTATION_COMMIT=9fcb88b9d6914c456d6800cc84c3cd0a6ac93f18
+DOCUMENTATION_COMMIT=1f91ea806ff8f3184b7f4e00fc6e69b1e23a08a2
if [[ ${PV} == 9999* ]]; then
inherit git-r3