aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-26 16:08:28 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2022-11-26 16:18:06 +0100
commit707031ef7c74098969e56df60ca56f23547fee1a (patch)
tree26eb411a2b663d9b010fca71083fd6079311a41d /app-backup
parentapp-backup/timeshift: drop 22.06.1-r1 (diff)
downloadguru-707031ef7c74098969e56df60ca56f23547fee1a.tar.gz
guru-707031ef7c74098969e56df60ca56f23547fee1a.tar.bz2
guru-707031ef7c74098969e56df60ca56f23547fee1a.zip
app-backup/timeshift-22.06.5: revbump, use make instead of emake
- update xdg icon cache after install Closes: https://bugs.gentoo.org/849626 Closes: https://bugs.gentoo.org/849629 Bug: https://bugs.gentoo.org/883157 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/timeshift/Manifest2
-rw-r--r--app-backup/timeshift/timeshift-22.06.5-r1.ebuild (renamed from app-backup/timeshift/timeshift-22.06.5.ebuild)13
2 files changed, 12 insertions, 3 deletions
diff --git a/app-backup/timeshift/Manifest b/app-backup/timeshift/Manifest
index 3662b0f5c..ad6c06463 100644
--- a/app-backup/timeshift/Manifest
+++ b/app-backup/timeshift/Manifest
@@ -1,3 +1,3 @@
DIST timeshift-21.09.1.tar.gz 1401994 BLAKE2B 5b1b3650fadb02745150d8996b46b53be473c66c73d4f5209c4f8634f58c4019905524516089b9f2a77b3bf1dcc49ee4db5ac9cbd2c1419683ead01e2e36b4e7 SHA512 0e79b41861c1eb041e0592508636f87f77ca240001b238e9e70239898d9a66bcf367380e830682fb8671ade7c1cbdb10ca8c89585f2cb30de35c7480a0fa792b
-DIST timeshift-22.06.5.tar.gz 1494015 BLAKE2B 915bfabf78a6ad8b7212dc1c47b9a31467a3f38b7890e5a958d007e2ac8e5b6f226cffe693bc618fce56fb2dbbb951df1bd4e988052320b1dd98bb1953ce85c7 SHA512 6a24b7164f522e443bd1cc0646b867eeebf7ecb4bfb2948701a7b72571bd1f83fc8f372d82b7422ed86fd246291b76cf7061e347dc61132cc809163cd38e7756
+DIST timeshift-22.06.5-r1.tar.gz 1494015 BLAKE2B 915bfabf78a6ad8b7212dc1c47b9a31467a3f38b7890e5a958d007e2ac8e5b6f226cffe693bc618fce56fb2dbbb951df1bd4e988052320b1dd98bb1953ce85c7 SHA512 6a24b7164f522e443bd1cc0646b867eeebf7ecb4bfb2948701a7b72571bd1f83fc8f372d82b7422ed86fd246291b76cf7061e347dc61132cc809163cd38e7756
DIST timeshift-22.11.1.tar.gz 1490993 BLAKE2B ddee86cada8cb9982725c754977f96d260b161a15a12086fcd325d9da9789b6600a3d99d44d8c6fbe60ed39187c93f3bfde62dc889c2217219a44121d831f58f SHA512 cd5226e2400743ce0c1da077103caeb61f320c73e5fb409f57c0f10bba5c06893bcc0e5e588fb03b397ffbd76bb43498f18e70e5964947ad950d4edfe1dd6967
diff --git a/app-backup/timeshift/timeshift-22.06.5.ebuild b/app-backup/timeshift/timeshift-22.06.5-r1.ebuild
index 4055bcb37..b4e15c50f 100644
--- a/app-backup/timeshift/timeshift-22.06.5.ebuild
+++ b/app-backup/timeshift/timeshift-22.06.5-r1.ebuild
@@ -48,9 +48,13 @@ src_prepare() {
src_compile() {
tc-export CC
if use gtk; then
- emake all
+ # can't use emake here, fails to compile because some files getting removed
+ # during compilation, which are missing afterwards.
+ # https://bugs.gentoo.org/883157
+ # Pascal Jäger <pascal.jaeger@leimstift.de> (2022-11-26)
+ make all || die
else
- emake app-console
+ make app-console || die
fi
emake manpage
}
@@ -65,6 +69,7 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
if ! use gtk; then
elog ""
elog "Installed timeshift without gtk GUI."
@@ -73,3 +78,7 @@ pkg_postinst() {
fi
optfeature "btrfs support" sys-fs/btrfs-progs
}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}