aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2022-03-06 01:39:18 +0000
committerAisha Tammy <gentoo@aisha.cc>2022-03-06 01:39:42 +0000
commite92bc3fc3e0f98accb6d0ef8c44c89da62e1c626 (patch)
tree521e3276d61aebb45a51d2ecfbe6f49f95f9a755 /app-arch
parentsys-kernel/uek-sources: drop old version (diff)
downloadguru-e92bc3fc3e0f98accb6d0ef8c44c89da62e1c626.tar.gz
guru-e92bc3fc3e0f98accb6d0ef8c44c89da62e1c626.tar.bz2
guru-e92bc3fc3e0f98accb6d0ef8c44c89da62e1c626.zip
app-arch/libarchive-qt: version bump to 2.0.7
move to meson eclass Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive-qt/Manifest1
-rw-r--r--app-arch/libarchive-qt/libarchive-qt-2.0.7.ebuild39
-rw-r--r--app-arch/libarchive-qt/libarchive-qt-9999.ebuild10
3 files changed, 45 insertions, 5 deletions
diff --git a/app-arch/libarchive-qt/Manifest b/app-arch/libarchive-qt/Manifest
index 5d096def6..ed1cd107d 100644
--- a/app-arch/libarchive-qt/Manifest
+++ b/app-arch/libarchive-qt/Manifest
@@ -1 +1,2 @@
DIST libarchive-qt-2.0.6.tar.gz 99095 BLAKE2B 57089d64179344a621d9d8be993b77f299a18a3cbd727c79adde2f7821e2cd5ca4a750ddd8707622de1c929f7f8ba3d4c42238f3d86d924e0fc42f73950acd30 SHA512 aa25952a585724579c4f8885414b7f343d958f576bfd8278c09cdec0f8ca776bb6480b5e3e545c33adbbd3c980ff20ce36ee37cc754df2971e77b04292a05828
+DIST libarchive-qt-2.0.7.tar.gz 99012 BLAKE2B fbb688ce08bedf4dd076c1efba213b162181862bb1560aaeab6d5ca191874d4ce4961c30e0a7497f81dc8ac7736a2ebae484883c38edde015a6eb0e0d2eda9d9 SHA512 6d61d267ec527fd61f2d79074eee0f1df80ba722468d0d890492de6dd47590771fff8f8d51b2bf6b552c033ed74cff8faaed51166591e69888e58d1298231fad
diff --git a/app-arch/libarchive-qt/libarchive-qt-2.0.7.ebuild b/app-arch/libarchive-qt/libarchive-qt-2.0.7.ebuild
new file mode 100644
index 000000000..82202f1ed
--- /dev/null
+++ b/app-arch/libarchive-qt/libarchive-qt-2.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg meson
+
+DESCRIPTION="A Qt based archiving solution with libarchive backend"
+HOMEPAGE="https://gitlab.com/marcusbritanicus/libarchive-qt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/marcusbritanicus/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/marcusbritanicus/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="
+ app-arch/libarchive[lzma,bzip2,zlib(+)]
+ app-arch/lrzip
+ app-arch/lzip
+ app-arch/lzop
+ dev-qt/qtgui:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use static-libs install_static)
+ )
+ meson_src_configure
+}
diff --git a/app-arch/libarchive-qt/libarchive-qt-9999.ebuild b/app-arch/libarchive-qt/libarchive-qt-9999.ebuild
index 2ad5a6ded..82202f1ed 100644
--- a/app-arch/libarchive-qt/libarchive-qt-9999.ebuild
+++ b/app-arch/libarchive-qt/libarchive-qt-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit xdg cmake
+inherit xdg meson
DESCRIPTION="A Qt based archiving solution with libarchive backend"
HOMEPAGE="https://gitlab.com/marcusbritanicus/libarchive-qt"
@@ -32,8 +32,8 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
- local mycmakeargs=(
- -DINSTALL_STATIC=$(usex static-libs)
+ local emesonargs=(
+ $(meson_use static-libs install_static)
)
- cmake_src_configure
+ meson_src_configure
}