aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-01-19 19:08:42 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-01-19 19:09:45 +0100
commita054e04909af0ae8ba8ae0cde4bb436830bf0953 (patch)
tree976da3891aac244f6fdca8d5532d8c6e1dbccb9f /app-admin
parentapp-admin/himitsu: drop 0.3 (diff)
downloadguru-a054e04909af0ae8ba8ae0cde4bb436830bf0953.tar.gz
guru-a054e04909af0ae8ba8ae0cde4bb436830bf0953.tar.bz2
guru-a054e04909af0ae8ba8ae0cde4bb436830bf0953.zip
app-admin/himitsu: add 0.5
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/himitsu/Manifest1
-rw-r--r--app-admin/himitsu/himitsu-0.5.ebuild35
-rw-r--r--app-admin/himitsu/himitsu-9999.ebuild6
3 files changed, 39 insertions, 3 deletions
diff --git a/app-admin/himitsu/Manifest b/app-admin/himitsu/Manifest
index 7bb2e378e..e25c8ff75 100644
--- a/app-admin/himitsu/Manifest
+++ b/app-admin/himitsu/Manifest
@@ -1 +1,2 @@
DIST himitsu-0.4.tar.gz 42135 BLAKE2B 3921887f8398890b43b8f9219bdfa5dac2c44689c2b52e605d447795469827a3fbe86dec227fa799cd38926c0c2cb727feef885ab03658eec13f7239fcbd98cb SHA512 a42b8088f0ddf8931347fc16d5b6404e21e7603025d444e734beeb57da3f9fefdc4e55993dd613ef77d3eb9448fd9acf43c109dc199e97e5d259a3f5a3267571
+DIST himitsu-0.5.tar.gz 42924 BLAKE2B 808a62c13e950d102f27c3219f15b23ed414ec5d9e9029dee0ac8e1b217d199fe9ade707d23a3f016098e661e4416e5d8aaa445a55caaed834444a266ba29d7b SHA512 6e9c304df824814179dd99e67dbed6c78860127eabe73df13d7b8f06e32cf47700cb7e1450e862d68ad4e1004d5feb9195cb1b91849b8b8436a1d149d5d0ace2
diff --git a/app-admin/himitsu/himitsu-0.5.ebuild b/app-admin/himitsu/himitsu-0.5.ebuild
new file mode 100644
index 000000000..42c50e91f
--- /dev/null
+++ b/app-admin/himitsu/himitsu-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/himitsu"
+ SLOT="0"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/himitsu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+ SLOT="0/${PV}"
+fi
+
+DESCRIPTION="Secret storage system for Unix, suitable for storing passwords, keys, ..."
+HOMEPAGE="https://git.sr.ht/~sircmpwn/himitsu"
+LICENSE="GPL-3"
+
+IUSE=""
+
+DEPEND="
+ >=dev-lang/hare-0_pre20231127-r1:=
+"
+RDEPEND="
+ gui-apps/hiprompt-gtk-py
+"
+BDEPEND="app-text/scdoc"
+
+# binaries are hare-built
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_configure() {
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}
diff --git a/app-admin/himitsu/himitsu-9999.ebuild b/app-admin/himitsu/himitsu-9999.ebuild
index 035031894..42c50e91f 100644
--- a/app-admin/himitsu/himitsu-9999.ebuild
+++ b/app-admin/himitsu/himitsu-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ "${PV}" = "9999" ]]; then
inherit git-r3
@@ -20,7 +20,7 @@ LICENSE="GPL-3"
IUSE=""
DEPEND="
- dev-lang/hare:=
+ >=dev-lang/hare-0_pre20231127-r1:=
"
RDEPEND="
gui-apps/hiprompt-gtk-py