aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2022-12-17 10:14:44 +0200
committerViorel Munteanu <ceamac@gentoo.org>2022-12-17 10:16:08 +0200
commitbfc27770bc714e719de5beba6f624138a1f3d6d5 (patch)
treeeafaf141238aa3201b02d7890e232b0108dc6383
parentnet-misc/maestral: add 1.6.5 (diff)
downloadguru-bfc27770bc714e719de5beba6f624138a1f3d6d5.tar.gz
guru-bfc27770bc714e719de5beba6f624138a1f3d6d5.tar.bz2
guru-bfc27770bc714e719de5beba6f624138a1f3d6d5.zip
net-misc/maestral-qt: add 1.6.5
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--net-misc/maestral-qt/Manifest1
-rw-r--r--net-misc/maestral-qt/maestral-qt-1.6.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/maestral-qt/Manifest b/net-misc/maestral-qt/Manifest
index 1eff719dd..cde4aef04 100644
--- a/net-misc/maestral-qt/Manifest
+++ b/net-misc/maestral-qt/Manifest
@@ -1,2 +1,3 @@
DIST maestral-qt-1.5.3.tar.gz 1209467 BLAKE2B d810df1f7e21938b81565afb16049e385c5de1e295d64feeaa317966e139ddc76542a747db71ae76dc1c82a11ec7e266b69968cefa2839878941def4af7711f8 SHA512 fbc8723d6751e31504529a62f00f7becd4531d8613559edde2a4725bc0d5ac783e6c817814059489bead87923135462a871cdffd0f8d1f0f06481df20efde4f5
DIST maestral-qt-1.6.4.gh.tar.gz 1217974 BLAKE2B 1f6f68e9e1d28f1c0a31d39f81061afa462da412b43b7fc3dc232b8bcb5b20f0fd6c908bc5063cb943ba3ee7dc78029f5596ae81c2900c0830e6fdeaf62b2b12 SHA512 c6e5035746d33c2254cf39270498d5d3f0167cf22a6bd54d418a2e48990fd8e49eed846c74991e96816810585cce3fff023803378da6bcced96f38a248a9ff47
+DIST maestral-qt-1.6.5.gh.tar.gz 1217959 BLAKE2B fb57171e3b6ed286e03d143e0fbd7dba0eae69bd4402c271bd9897549d84f3b509f459577f0c44ba252bca6a9b651d70bd825565e2afdb86a97966a728803eaf SHA512 f34ca35fad1b1509a1cea605974c5f0ffb79763c2e6e6dcf68454246dd303d67274e1e46954270cd0d2eb171a427af2ef477cc19d0bb05634a3aeb593f69d7aa
diff --git a/net-misc/maestral-qt/maestral-qt-1.6.5.ebuild b/net-misc/maestral-qt/maestral-qt-1.6.5.ebuild
new file mode 100644
index 000000000..178cfd17e
--- /dev/null
+++ b/net-misc/maestral-qt/maestral-qt-1.6.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit desktop distutils-r1
+
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/PyQt6[widgets,gui,${PYTHON_USEDEP}]
+ ~net-misc/maestral-${PV}[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ domenu src/maestral_qt/resources/maestral.desktop
+}