aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2022-12-18 14:36:44 +0500
committerDenis Reva <denis7774@gmail.com>2022-12-18 14:37:38 +0500
commitaffc1daa905725a7a1b529ef352df22dbd5dac1e (patch)
tree4c76491b8f7f5f0e52a9c699550751572bf4ab80
parentdev-libs/gbinder: Updated in order to fix waydroid (diff)
downloadguru-affc1daa905725a7a1b529ef352df22dbd5dac1e.tar.gz
guru-affc1daa905725a7a1b529ef352df22dbd5dac1e.tar.bz2
guru-affc1daa905725a7a1b529ef352df22dbd5dac1e.zip
app-emulation/waydroid: Work in progress
Signed-off-by: Denis Reva <denis7774@gmail.com>
-rw-r--r--app-emulation/waydroid/Manifest1
-rw-r--r--app-emulation/waydroid/waydroid-1.3.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/waydroid/Manifest b/app-emulation/waydroid/Manifest
index 1514b8248..3013545ee 100644
--- a/app-emulation/waydroid/Manifest
+++ b/app-emulation/waydroid/Manifest
@@ -1 +1,2 @@
DIST waydroid-1.2.1.tar.gz 222939 BLAKE2B ce69cb5ded92653b9e3c02e89e8ddab1e34ef8d4b16d1863119346495829efe6baae4bf0171d284186e0042602bf351c3926a3a900bc884f2906c9f09b62b290 SHA512 4e4aa781b84501ccde444281ab93b6c45cf91d7cda2f04565bf43bc8cdcd529b987356278f9e369a71fbb249b3bcdbd0ea56d37d48d0fbf1bf8bf186b4383a43
+DIST waydroid-1.3.4.tar.gz 231638 BLAKE2B 73418208e484172745208caa89442478643327a77a8642536a26c538129ce57e643728a22d64393b4d344502b221b124c4000c1df0838aefc5af6996e7e8bab3 SHA512 2c7feb8cfe2b6e2738159d07e12f378250f5ba6a0d0f47c0ff904af934eacde193ae0fcae1cb4fb67d1687a2ffcd2864c1eea4fa5e52c19685ffad5c702359a5
diff --git a/app-emulation/waydroid/waydroid-1.3.4.ebuild b/app-emulation/waydroid/waydroid-1.3.4.ebuild
new file mode 100644
index 000000000..15651371e
--- /dev/null
+++ b/app-emulation/waydroid/waydroid-1.3.4.ebuild
@@ -0,0 +1,54 @@
+#Relaismatrix/ Messung Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit linux-info python-single-r1
+
+DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
+HOMEPAGE="https://waydro.id"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="systemd"
+
+DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )
+ sys-kernel/linux-headers"
+RDEPEND="
+ app-containers/lxc[systemd?]
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/gbinder[${PYTHON_USEDEP}]
+ ')
+ net-firewall/nftables[modern-kernel]
+ net-dns/dnsmasq \
+ ${PYTHON_DEPS}
+"
+
+CONFIG_CHECK="
+ ~ANDROID_BINDER_IPC
+ ~ANDROID_BINDERFS
+ ~MEMFD_CREATE
+"
+ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
+ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
+ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers, therefore it's vital for android-specific memory management"
+src_install() {
+ python_fix_shebang waydroid.py
+ mv waydroid.py waydroid || die
+ python_doscript waydroid
+ python_domodule tools
+ python_domodule data
+ insinto "/usr/share/applications"
+ doins "data/Waydroid.desktop"
+ insinto "/etc/gbinder.d"
+ doins "gbinder/anbox.conf"
+ if use systemd; then
+ insinto "/usr/lib/systemd/system"
+ doins "debian/waydroid-container.service"
+ fi
+}