aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-09-23 17:17:40 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-09-23 17:17:40 +0900
commit9fa5f3aa777566afb08a132a6c0d43436ec4e632 (patch)
tree5bec758f92a1ffe6f4e5a0a957b1e74458fde413
parentsys-apps/lact: drop 0.5.5 (diff)
downloadguru-9fa5f3aa777566afb08a132a6c0d43436ec4e632.tar.gz
guru-9fa5f3aa777566afb08a132a6c0d43436ec4e632.tar.bz2
guru-9fa5f3aa777566afb08a132a6c0d43436ec4e632.zip
dev-python/templated-dictionary: add 1.5
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
-rw-r--r--dev-python/templated-dictionary/Manifest1
-rw-r--r--dev-python/templated-dictionary/templated-dictionary-1.5.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/templated-dictionary/Manifest b/dev-python/templated-dictionary/Manifest
index f3a177a95..e4e0d618f 100644
--- a/dev-python/templated-dictionary/Manifest
+++ b/dev-python/templated-dictionary/Manifest
@@ -1 +1,2 @@
DIST templated-dictionary-1.4.gh.tar.gz 15384 BLAKE2B 50e5cb2762433526c6eed4f3f77050aae4c9d3a99b4340f1f8b0730825761be03e85b456855939089b26c807acd800d122d2dda5a688d73ab342c31d8af1d797 SHA512 d0c01cf53688192d29cea24d98e86d9f3f555c73ddbdf36297c0e0974b75b88257deb1a70a61e7197f90d6c62ce24fa524d4cdba561742401a439e45ae549fc1
+DIST templated-dictionary-1.5.gh.tar.gz 16163 BLAKE2B 8ec345576df2ce60f1837ee33275659da36805c4947c1d7d0d530ef74117e2926312c2f1e965dab1fbf7b20737be6511c91edb4948265d40e9b1c5adb5885933 SHA512 4bc82fb43b77574f0c28c02b3da871f51a3c1bb1f6b9377b9e064dce32edbfffc189e7eae700862ae528709640a45727d5a153447e35b3e92551f9e36cb0e073
diff --git a/dev-python/templated-dictionary/templated-dictionary-1.5.ebuild b/dev-python/templated-dictionary/templated-dictionary-1.5.ebuild
new file mode 100644
index 000000000..4b4309d8f
--- /dev/null
+++ b/dev-python/templated-dictionary/templated-dictionary-1.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python dictionary with Jinja2 expansion"
+HOMEPAGE="
+ https://github.com/xsuchy/templated-dictionary/
+ https://pypi.org/project/templated-dictionary/
+"
+SRC_URI="https://github.com/xsuchy/templated-dictionary/archive/refs/tags/python-${P}-1.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/${PN}-python-${P}-1"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"