aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-04-01 06:56:53 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-04-01 06:56:53 +0200
commit7620cb3e3f8a0cc71917e489bc2af7ca9a11e000 (patch)
treede06c084e0ca486c01768f72c466a23c40057388
parentmedia-sound/tavu: treeclean, no release & no code commit for 3 years (diff)
downloadguru-7620cb3e3f8a0cc71917e489bc2af7ca9a11e000.tar.gz
guru-7620cb3e3f8a0cc71917e489bc2af7ca9a11e000.tar.bz2
guru-7620cb3e3f8a0cc71917e489bc2af7ca9a11e000.zip
app-admin/himitsu-totp: add 0.1
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--app-admin/himitsu-totp/Manifest1
-rw-r--r--app-admin/himitsu-totp/himitsu-totp-0.1.ebuild32
-rw-r--r--app-admin/himitsu-totp/himitsu-totp-9999.ebuild13
3 files changed, 34 insertions, 12 deletions
diff --git a/app-admin/himitsu-totp/Manifest b/app-admin/himitsu-totp/Manifest
new file mode 100644
index 000000000..a5701767e
--- /dev/null
+++ b/app-admin/himitsu-totp/Manifest
@@ -0,0 +1 @@
+DIST himitsu-totp-0.1.tar.gz 15188 BLAKE2B c5165556e67440e847f9ee6ab653705f22953b08a678e6a865e9d0fe2946b8ad755e685b62b0bdf5dc9c5f44698d85c8095bd8b2b43f5731721c26e407868955 SHA512 767dbfc0bee2942e4b2a75ea2e76ec39f06bcc979cd6f6f1e63d7e64d4f26c311458f47c282915f0e6f4ea39582510b4f516ac76251acb617105495f9bdfeb30
diff --git a/app-admin/himitsu-totp/himitsu-totp-0.1.ebuild b/app-admin/himitsu-totp/himitsu-totp-0.1.ebuild
new file mode 100644
index 000000000..cefe488ad
--- /dev/null
+++ b/app-admin/himitsu-totp/himitsu-totp-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/himitsu-totp"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/himitsu-totp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="TOTP support for Himitsu"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/himitsu-totp"
+LICENSE="GPL-3"
+SLOT="0"
+
+
+RDEPEND="app-admin/himitsu:="
+DEPEND="
+ ${RDEPEND}
+ dev-lang/hare:=
+"
+BDEPEND="app-text/scdoc"
+
+# hare binary
+QA_FLAGS_IGNORED="usr/bin/hitotp"
+
+src_configure() {
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}
diff --git a/app-admin/himitsu-totp/himitsu-totp-9999.ebuild b/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
index 59be0c7b2..cefe488ad 100644
--- a/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
+++ b/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,17 +27,6 @@ BDEPEND="app-text/scdoc"
# hare binary
QA_FLAGS_IGNORED="usr/bin/hitotp"
-src_prepare() {
- default
-
- sed -i 's|^use query;|use himitsu::query;|' cmd/hitotp/main.ha || die
-}
-
src_configure() {
sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
}
-
-src_install() {
- einstalldocs
- dobin hitotp
-}