aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang Müller <wolf@oriole.systems>2024-10-03 12:07:55 +0200
committerWolfgang Müller <wolf@oriole.systems>2024-10-03 12:07:55 +0200
commit5e7905c25b6f9a839e43e40cca383ce2eb425cdb (patch)
tree3cdc1ad8252234798fa9c404033ff08137680e4e
parentwww-apps/sblg: respect LDFLAGS and don't call CC and AR directly (diff)
downloadguru-5e7905c25b6f9a839e43e40cca383ce2eb425cdb.tar.gz
guru-5e7905c25b6f9a839e43e40cca383ce2eb425cdb.tar.bz2
guru-5e7905c25b6f9a839e43e40cca383ce2eb425cdb.zip
www-apps/sblg: mark implicit decls as expected
The specific flavour of configure script, oconfigure [1], tests for various BSD functionality that is missing on Linux. This triggers -Wimplicit-function-declaration but can safely be silenced. [1] https://github.com/kristapsdz/oconfigure Closes: https://bugs.gentoo.org/940688 Signed-off-by: Wolfgang Müller <wolf@oriole.systems>
-rw-r--r--www-apps/sblg/sblg-0.5.12.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/www-apps/sblg/sblg-0.5.12.ebuild b/www-apps/sblg/sblg-0.5.12.ebuild
index 4d3f3300b..bfc69619a 100644
--- a/www-apps/sblg/sblg-0.5.12.ebuild
+++ b/www-apps/sblg/sblg-0.5.12.ebuild
@@ -17,6 +17,24 @@ IUSE="examples"
DEPEND="dev-libs/expat"
RDEPEND="${DEPEND}"
+# oconfigure specifically tests for BSD functionality on Linux
+QA_CONFIG_IMPL_DECL_SKIP=(
+ crypt_newhash
+ crypt_checkpass
+ warnc
+ errc
+ getexecname
+ getprogname
+ memset_s
+ pledge
+ recallocarray
+ strtonum
+ TAILQ_FOREACH_SAFE
+ timingsafe_bcmp
+ timingsafe_memcmp
+ unveil
+)
+
src_configure() {
tc-export CC AR