aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-07-15 00:52:47 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-07-15 00:56:04 +0900
commit41a4a1c1e5eb030f9758fd5288ef254de44d29f2 (patch)
tree115f96be4a7e07d4efe8818aa09f181a65974728
parentdev-libs/fastText: enable py3.13 (diff)
downloadguru-41a4a1c1e5eb030f9758fd5288ef254de44d29f2.tar.gz
guru-41a4a1c1e5eb030f9758fd5288ef254de44d29f2.tar.bz2
guru-41a4a1c1e5eb030f9758fd5288ef254de44d29f2.zip
dev-python/pymeeus: enable py3.13
Closes: https://bugs.gentoo.org/928258 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
-rw-r--r--dev-python/pymeeus/files/pymeeus-0.5.12-pytest8.patch88
-rw-r--r--dev-python/pymeeus/metadata.xml5
-rw-r--r--dev-python/pymeeus/pymeeus-0.5.12.ebuild7
3 files changed, 98 insertions, 2 deletions
diff --git a/dev-python/pymeeus/files/pymeeus-0.5.12-pytest8.patch b/dev-python/pymeeus/files/pymeeus-0.5.12-pytest8.patch
new file mode 100644
index 000000000..90fbf7921
--- /dev/null
+++ b/dev-python/pymeeus/files/pymeeus-0.5.12-pytest8.patch
@@ -0,0 +1,88 @@
+https://bugs.gentoo.org/928258
+https://github.com/architest/pymeeus/issues/24
+From f064abfda6b3cb48cb42a6827cd250413056f227 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Antoine=20Beaupr=C3=A9?= <anarcat@debian.org>
+Date: Sat, 6 Apr 2024 22:22:52 -0400
+Subject: [PATCH] fix pytest 7.2 compatibility
+
+Pytest 7.2 deprecated plain top-level `setup()` and `teardown()`
+functions in favor of their own decorators:
+
+https://docs.pytest.org/en/latest/changelog.html#pytest-7-2-0-2022-10-23
+https://docs.pytest.org/en/latest/deprecations.html#setup-teardown
+
+Now we need to use module-level setup/teardown, which is extremely
+similar, just named differently:
+
+https://docs.pytest.org/en/latest/how-to/xunit_setup.html#module-level-setup-teardown
+
+We keep compatibility shims for older pytest releases.
+
+Closes: #24
+---
+ tests/test_curvefitting.py | 10 +++++++---
+ tests/test_interpolation.py | 9 +++++++--
+ 2 files changed, 14 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_curvefitting.py b/tests/test_curvefitting.py
+index 9398327..0d20cca 100644
+--- a/tests/test_curvefitting.py
++++ b/tests/test_curvefitting.py
+@@ -31,9 +31,8 @@
+ cf4 = CurveFitting()
+
+
+-def setup():
++def setup_module():
+ """This function is used to set up the environment for the tests"""
+-
+ # Set up a few CurveFitting objects
+ cf1.set([73.0, 38.0, 35.0, 42.0, 78.0, 68.0, 74.0, 42.0, 52.0, 54.0, 39.0,
+ 61.0, 42.0, 49.0, 50.0, 62.0, 44.0, 39.0, 43.0, 54.0, 44.0, 37.0],
+@@ -58,10 +57,15 @@ def setup():
+ -0.8372, -0.4377, -0.3640, -0.3508, -0.2126])
+
+
+-def teardown():
++def teardown_module():
+ pass
+
+
++# pre pytest 7.2 compatibility
++setup = setup_module
++teardown = teardown_module
++
++
+ # CurveFitting class
+
+ def test_curvefitting_constructor():
+diff --git a/tests/test_interpolation.py b/tests/test_interpolation.py
+index e853c37..08f7b6e 100644
+--- a/tests/test_interpolation.py
++++ b/tests/test_interpolation.py
+@@ -32,7 +32,7 @@
+ i_sine = Interpolation()
+
+
+-def setup():
++def setup_module():
+ """This function is used to set up the environment for the tests"""
+ # Set up a interpolation object which uses Right Ascension
+ y0 = Angle(10, 18, 48.732, ra=True)
+@@ -64,10 +64,15 @@ def setup():
+ 0.5236885653, 0.5453707057])
+
+
+-def teardown():
++def teardown_module():
+ pass
+
+
++# pre pytest 7.2 ompatibility
++setup = setup_module
++teardown = teardown_module
++
++
+ # Interpolation class
+
+ def test_interpolation_constructor():
diff --git a/dev-python/pymeeus/metadata.xml b/dev-python/pymeeus/metadata.xml
index 05776cb32..977daa513 100644
--- a/dev-python/pymeeus/metadata.xml
+++ b/dev-python/pymeeus/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>pastalian46@gmail.com</email>
+ <name>Takuya Wakazono</name>
+ </maintainer>
<upstream>
<remote-id type="github">architest/pymeeus</remote-id>
<remote-id type="pypi">PyMeeus</remote-id>
diff --git a/dev-python/pymeeus/pymeeus-0.5.12.ebuild b/dev-python/pymeeus/pymeeus-0.5.12.ebuild
index aa3a9a724..aec1ee397 100644
--- a/dev-python/pymeeus/pymeeus-0.5.12.ebuild
+++ b/dev-python/pymeeus/pymeeus-0.5.12.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
DISTUTILS_USE_PEP517=setuptools
PYPI_PN="PyMeeus"
PYPI_NO_NORMALIZE=1
@@ -19,6 +19,11 @@ LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64"
+PATCHES=(
+ # bug #928258
+ "${FILESDIR}/${P}-pytest8.patch"
+)
+
distutils_enable_tests pytest
distutils_enable_sphinx docs/source \