aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-06-14 17:08:02 +0300
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-06-14 17:10:49 +0300
commit032e53b3053c5e6dcaac32928f7f900a33948fe2 (patch)
tree80d74674dc37e75480e0955a33242518e7048f1e
parentprofiles/updates: remove empty line (diff)
downloadguru-032e53b3053c5e6dcaac32928f7f900a33948fe2.tar.gz
guru-032e53b3053c5e6dcaac32928f7f900a33948fe2.tar.bz2
guru-032e53b3053c5e6dcaac32928f7f900a33948fe2.zip
sys-cluster/parsec: fix wrong LDFLAGS in .pc file
Closes: https://bugs.gentoo.org/810970 Closes: https://bugs.gentoo.org/810961 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
-rw-r--r--sys-cluster/parsec/parsec-3.0.2012-r2.ebuild (renamed from sys-cluster/parsec/parsec-3.0.2012-r1.ebuild)17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-cluster/parsec/parsec-3.0.2012-r1.ebuild b/sys-cluster/parsec/parsec-3.0.2012-r2.ebuild
index 26286f3dc..c6cb03d99 100644
--- a/sys-cluster/parsec/parsec-3.0.2012-r1.ebuild
+++ b/sys-cluster/parsec/parsec-3.0.2012-r2.ebuild
@@ -7,7 +7,7 @@ DOCS_BUILDER="doxygen"
DOCS_DIR="docs/doxygen"
PYTHON_COMPAT=( python3_{8..11} pypy3 )
-inherit cmake edo fortran-2 docs python-single-r1
+inherit cmake fortran-2 docs python-single-r1
DESCRIPTION="Parallel Runtime Scheduler and Execution Controller"
HOMEPAGE="
@@ -98,10 +98,17 @@ pkg_setup() {
}
src_prepare() {
- edo sed \
- -e "s|\${CMAKE_INSTALL_PREFIX}/|${D}/\${CMAKE_INSTALL_PREFIX}/|g" \
- -e "s|--prefix|--root ${D} --prefix|g" \
- -i tools/profiling/python/CMakeLists.txt
+ # cannot use ${D} in src_prepare, just skip this directory, it doesn't get installed
+ sed '/profiling/d' tools/CMakeLists.txt || die
+
+ # 810970 remove unwanted flags from parsec.pc
+ sed -i -e "s/ @EXTRA_CFLAGS@//" -e "s/ @EXTRA_LDFLAGS@//" parsec/include/parsec.pc.in || die
+
+ # 810961: 2 tests fail, 2 time out
+ sed -i -e "/unit_dtd_war_shm/d" -e "/unit_dtd_war_mpi/d" tests/interfaces/superscalar/CMakeLists.txt || die
+ sed -i -e "/unit_haar_tree_mpi/d" tests/haar-tree-project/CMakeLists.txt || die
+ sed -i -e "/unit_merge_sort_mpi/d" tests/merge_sort/Testings.cmake || die
+
cmake_src_prepare
}