aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2018-12-28 20:43:22 +0300
committerArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2018-12-28 20:43:22 +0300
commit85250a010301c191bec13c1abc6f74a076f07b98 (patch)
tree016312260392ae5afb11d58b3e7fa03bafa6f52d /www-servers/xsp
parentMerge pull request #408 from woodworker/patch-2 (diff)
downloaddotnet-85250a010301c191bec13c1abc6f74a076f07b98.tar.gz
dotnet-85250a010301c191bec13c1abc6f74a076f07b98.tar.bz2
dotnet-85250a010301c191bec13c1abc6f74a076f07b98.zip
new commit sha1, and exclude examples by default
Diffstat (limited to 'www-servers/xsp')
-rw-r--r--www-servers/xsp/Manifest1
-rw-r--r--www-servers/xsp/xsp-4.6.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/www-servers/xsp/Manifest b/www-servers/xsp/Manifest
index 538bccb..bd732de 100644
--- a/www-servers/xsp/Manifest
+++ b/www-servers/xsp/Manifest
@@ -1 +1,2 @@
DIST xsp-4.4_p2016022603.tar.gz 307876 SHA256 3a3fd02cefd7db448d9ea61ea739cc488e6f9606d56f8458edb6e7b9d730c060 SHA512 2bb4a8509a31b661a720518ce5db2e039bfafc60743a4959e3de11edc825334985c0fed1fe6e81e9e794ed0e801a2051198c395b57e213bf82757a545e1ddc5a WHIRLPOOL 437f0fc41b09d7f4cdf3b4eec62e963a24bca713a0148ebdce53578df4708c35055d395be0ffb121ae8277934c4a928b6b0f022636269b0a4ad97187569f8301
+DIST xsp-4.6.tar.gz 307664 SHA256 3e64310f7fcc1b626dfb936f8bfc44145b2566433eefd5e94112af42a6e527d5 SHA512 f6d9ac44daf356358588fa9676797d62d4f77244dfc917de5c8a86c73930d942452ad686f06b3fda42513eeffe48250d7d7d65ed36018620561aa40096fb36a9 WHIRLPOOL 682b77eabc1b544621b364daf3a7ce3bdae962fd4c5fb0840c83074d0d5376bb2aed141192773228f46edcf9dfae0368cd03b6cc3563bea096d0ae733b12f4c4
diff --git a/www-servers/xsp/xsp-4.6.ebuild b/www-servers/xsp/xsp-4.6.ebuild
new file mode 100644
index 0000000..ab97803
--- /dev/null
+++ b/www-servers/xsp/xsp-4.6.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+USE_DOTNET="net45 net40 net35"
+PATCHDIR="${FILESDIR}/2.2/"
+
+inherit eutils systemd dotnet user autotools msbuild
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+
+EGIT_COMMIT="e1494fcb8c12e329631f8f335732bcaf318a4ec7"
+SRC_URI="https://codeload.github.com/mono/xsp/tar.gz/${EGIT_COMMIT} -> ${PN}-${PV}.tar.gz"
+RESTRICT="mirror"
+S="${WORKDIR}/xsp-${EGIT_COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+${USE_DOTNET} doc test examples developer debug"
+
+COMMON_DEPEND="dev-db/sqlite:3
+ !dev-dotnet/xsp
+ "
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/aclocal-fix.patch"
+
+ if [ -z "$LIBTOOL" ]; then
+ LIBTOOL=`which glibtool 2>/dev/null`
+ if [ ! -x "$LIBTOOL" ]; then
+ LIBTOOL=`which libtool`
+ fi
+ fi
+ eaclocal -I build/m4/shamrock -I build/m4/shave $ACLOCAL_FLAGS
+ if test -z "$NO_LIBTOOLIZE"; then
+ ${LIBTOOL}ize --force --copy
+ fi
+ eapply_user
+ eautoconf
+}
+
+src_configure() {
+ eautomake --gnu --add-missing --force --copy #nowarn
+
+ myeconfargs=("--enable-maintainer-mode")
+ use test && myeconfargs+=("--with_unit_tests")
+ use doc || myeconfargs+=("--disable-docs")
+ econf ${myeconfargs}
+}
+
+src_compile() {
+ msbuild xsp.sln
+}
+
+pkg_preinst() {
+ enewgroup aspnet
+ enewuser aspnet -1 -1 /tmp aspnet
+
+ # enewuser www-data
+ # www-data - is from debian, i think it's the same as aspnet here
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ newinitd "${PATCHDIR}/xsp.initd" xsp
+ newconfd "${PATCHDIR}/xsp.confd" xsp
+
+ newinitd "${PATCHDIR}/mod-mono-server-r1.initd" mod-mono-server
+ newconfd "${PATCHDIR}/mod-mono-server.confd" mod-mono-server
+
+ insinto "/etc/xsp4"
+ doins "${FILESDIR}/systemd/mono.webapp"
+
+ keepdir "/etc/xsp4/conf.d/systemd"
+
+ if use doc; then
+ insinto /etc/xsp4/conf.d
+ doins "${FILESDIR}/systemd/readme.txt"
+ fi
+
+ if ! use examples; then
+ /bin/rm -rf "${ED}/usr/lib64/xsp/test" || die
+ fi
+
+ if test -z "$NO_LIBTOOLIZE"; then
+ ${LIBTOOL}ize --force --copy
+ fi
+
+ # mono-xsp4.service was original name from
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770458;filename=mono-xsp4.service;att=1;msg=5
+ # I think that using the same commands as in debian
+ # systemctl start mono-xsp4.service
+ # systemctl start mono-xsp4
+ # is better than to have shorter command
+ # systemctl start xsp
+ #
+ # insinto /usr/lib/systemd/system
+ systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
+
+ keepdir /var/run/aspnet
+}