aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <Arsen.Shnurkov@gmail.com>2016-10-01 11:19:02 +0300
committerArsenShnurkov <Arsen.Shnurkov@gmail.com>2016-10-01 11:19:02 +0300
commit1fb4a621456649232e01190adc47cae290be43ab (patch)
treeb6efb5591ab3d36e23e927b27a4ef7ea6b7b027c /dev-dotnet/newtonsoft-json
parentMerge pull request #250 from ArsenShnurkov/aspnet-common (diff)
downloaddotnet-1fb4a621456649232e01190adc47cae290be43ab.tar.gz
dotnet-1fb4a621456649232e01190adc47cae290be43ab.tar.bz2
dotnet-1fb4a621456649232e01190adc47cae290be43ab.zip
converting mine ebuilds to einstall_pc_file from eclass
Diffstat (limited to 'dev-dotnet/newtonsoft-json')
-rw-r--r--dev-dotnet/newtonsoft-json/newtonsoft-json-6.0.8.ebuild31
-rw-r--r--dev-dotnet/newtonsoft-json/newtonsoft-json-7.0.1_p20150831.ebuild31
-rw-r--r--dev-dotnet/newtonsoft-json/newtonsoft-json-8.0.1_p20151229.ebuild31
3 files changed, 3 insertions, 90 deletions
diff --git a/dev-dotnet/newtonsoft-json/newtonsoft-json-6.0.8.ebuild b/dev-dotnet/newtonsoft-json/newtonsoft-json-6.0.8.ebuild
index 1645ee5..ab30454 100644
--- a/dev-dotnet/newtonsoft-json/newtonsoft-json-6.0.8.ebuild
+++ b/dev-dotnet/newtonsoft-json/newtonsoft-json-6.0.8.ebuild
@@ -107,7 +107,7 @@ src_install() {
enupkg "${WORKDIR}/${NUSPEC_ID}.${NUSPEC_VERSION}.nupkg"
- install_pc_file
+ einstall_pc_file "${PN}" "${PV}" "${NAME}"
}
patch_nuspec_file()
@@ -127,32 +127,3 @@ patch_nuspec_file()
sed -i 's/<\/package>/'"${FILES_STRING//$'\n'/\\$'\n'}"'\n&/g' $1 || die "escaping line endings"
fi
}
-
-PC_FILE_NAME=${PN}
-
-install_pc_file()
-{
- if use pkg-config; then
- dodir /usr/$(get_libdir)/pkgconfig
- ebegin "Installing ${PC_FILE_NAME}.pc file"
- sed \
- -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PACKAGENAME@:${PC_FILE_NAME}:" \
- -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
- -e "s:@VERSION@:${PV}:" \
- -e 's*@LIBS@*-r:${libdir}'"/mono/${PC_FILE_NAME}/Newtonsoft.Json.dll"'*' \
- <<\EOF >"${D}/usr/$(get_libdir)/pkgconfig/${PC_FILE_NAME}.pc" || die
-prefix=${pcfiledir}/../..
-exec_prefix=${prefix}
-libdir=${exec_prefix}/@LIBDIR@
-Name: @PACKAGENAME@
-Description: @DESCRIPTION@
-Version: @VERSION@
-Libs: @LIBS@
-EOF
-
- einfo PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}"
- PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}" || die ".pc file failed to validate."
- eend $?
- fi
-} \ No newline at end of file
diff --git a/dev-dotnet/newtonsoft-json/newtonsoft-json-7.0.1_p20150831.ebuild b/dev-dotnet/newtonsoft-json/newtonsoft-json-7.0.1_p20150831.ebuild
index c5ff34a..c9d1e1e 100644
--- a/dev-dotnet/newtonsoft-json/newtonsoft-json-7.0.1_p20150831.ebuild
+++ b/dev-dotnet/newtonsoft-json/newtonsoft-json-7.0.1_p20150831.ebuild
@@ -106,7 +106,7 @@ src_install() {
enupkg "${WORKDIR}/${NUSPEC_ID}.${NUSPEC_VERSION}.nupkg"
- install_pc_file
+ einstall_pc_file "${PN}" "7.0" "${NAME}"
}
patch_nuspec_file()
@@ -126,32 +126,3 @@ patch_nuspec_file()
sed -i 's/<\/package>/'"${FILES_STRING//$'\n'/\\$'\n'}"'\n&/g' $1 || die "escaping line endings"
fi
}
-
-PC_FILE_NAME=${PN}
-
-install_pc_file()
-{
- if use pkg-config; then
- dodir /usr/$(get_libdir)/pkgconfig
- ebegin "Installing ${PC_FILE_NAME}.pc file"
- sed \
- -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PACKAGENAME@:${PC_FILE_NAME}:" \
- -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
- -e "s:@VERSION@:${PV}:" \
- -e 's*@LIBS@*-r:${libdir}'"/mono/${PC_FILE_NAME}/Newtonsoft.Json.dll"'*' \
- <<\EOF >"${D}/usr/$(get_libdir)/pkgconfig/${PC_FILE_NAME}.pc" || die
-prefix=${pcfiledir}/../..
-exec_prefix=${prefix}
-libdir=${exec_prefix}/@LIBDIR@
-Name: @PACKAGENAME@
-Description: @DESCRIPTION@
-Version: @VERSION@
-Libs: @LIBS@
-EOF
-
- einfo PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}"
- PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}" || die ".pc file failed to validate."
- eend $?
- fi
-} \ No newline at end of file
diff --git a/dev-dotnet/newtonsoft-json/newtonsoft-json-8.0.1_p20151229.ebuild b/dev-dotnet/newtonsoft-json/newtonsoft-json-8.0.1_p20151229.ebuild
index 93c41a6..aa8f4bd 100644
--- a/dev-dotnet/newtonsoft-json/newtonsoft-json-8.0.1_p20151229.ebuild
+++ b/dev-dotnet/newtonsoft-json/newtonsoft-json-8.0.1_p20151229.ebuild
@@ -106,7 +106,7 @@ src_install() {
enupkg "${WORKDIR}/${NUSPEC_ID}.${NUSPEC_VERSION}.nupkg"
- install_pc_file
+ einstall_pc_file "${PN}" "8.0" "${NAME}"
}
patch_nuspec_file()
@@ -126,32 +126,3 @@ patch_nuspec_file()
sed -i 's/<\/package>/'"${FILES_STRING//$'\n'/\\$'\n'}"'\n&/g' $1 || die "escaping line endings"
fi
}
-
-PC_FILE_NAME=${PN}
-
-install_pc_file()
-{
- if use pkg-config; then
- dodir /usr/$(get_libdir)/pkgconfig
- ebegin "Installing ${PC_FILE_NAME}.pc file"
- sed \
- -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PACKAGENAME@:${PC_FILE_NAME}:" \
- -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
- -e "s:@VERSION@:${PV}:" \
- -e 's*@LIBS@*-r:${libdir}'"/mono/${PC_FILE_NAME}/Newtonsoft.Json.dll"'*' \
- <<\EOF >"${D}/usr/$(get_libdir)/pkgconfig/${PC_FILE_NAME}.pc" || die
-prefix=${pcfiledir}/../..
-exec_prefix=${prefix}
-libdir=${exec_prefix}/@LIBDIR@
-Name: @PACKAGENAME@
-Description: @DESCRIPTION@
-Version: @VERSION@
-Libs: @LIBS@
-EOF
-
- einfo PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}"
- PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists "${PC_FILE_NAME}" || die ".pc file failed to validate."
- eend $?
- fi
-} \ No newline at end of file