summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild
index a5d0d5566031..55f6ab01b3be 100644
--- a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild,v 1.2 2009/10/08 17:32:40 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.2.0.ebuild,v 1.3 2010/08/07 13:50:35 ssuominen Exp $
EAPI=2
+EAUTORECONF=yes
inherit xfconf
DESCRIPTION="Disk usage and performance panel plugin"
@@ -14,13 +15,15 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-RDEPEND=">=xfce-base/xfce4-panel-4.3.90"
+RDEPEND=">=xfce-base/libxfcegui4-4.3.90
+ >=xfce-base/xfce4-panel-4.3.90"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
+ PATCHES=( "${FILESDIR}"/${P}-link_to_libxfcegui4.patch )
XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+ $(xfconf_use_debug)"
+ DOCS="AUTHORS ChangeLog NEWS README"
}