summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild')
-rw-r--r--xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
index 3ccc2a6a2d2b..a104a0236d59 100644
--- a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
+++ b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.3 2010/08/05 23:05:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.4 2010/08/24 03:05:39 ssuominen Exp $
EAPI=2
inherit xfconf
@@ -23,8 +23,18 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS THANKS"
+ # static, http://bugzilla.xfce.org/show_bug.cgi?id=6659
XFCONF="--disable-dependency-tracking
--disable-static
$(xfconf_use_debug)"
+ DOCS="AUTHORS ChangeLog NEWS THANKS"
+}
+
+src_prepare() {
+ # Encoding, http://bugzilla.xfce.org/show_bug.cgi?id=6660
+ sed -i \
+ -e '/Encoding/d' \
+ panel-plugin/datetime.desktop.in.in || die
+
+ xfconf_src_prepare
}