summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/boot0/boot0-6.2_beta1.ebuild')
-rw-r--r--sys-freebsd/boot0/boot0-6.2_beta1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/boot0-6.2_beta1.ebuild b/sys-freebsd/boot0/boot0-6.2_beta1.ebuild
new file mode 100644
index 000000000000..2af4523f33b5
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-6.2_beta1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-6.2_beta1.ebuild,v 1.1 2006/09/21 20:51:03 flameeyes Exp $
+
+inherit bsdmk freebsd
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+PATCHES="${FILESDIR}/boot0-6.0-gentoo.patch"
+
+src_unpack() {
+ freebsd_src_unpack
+
+ grep -Zlr -- -ffreestanding "${S}" | xargs -0 sed -i -e \
+ "s:-ffreestanding:-ffreestanding $(test-flags -fno-stack-protector -fno-stack-protector-all):g"
+}
+
+src_install() {
+ dodir /boot/defaults
+
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}