summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/omni/ChangeLog8
-rw-r--r--sys-devel/omni/Manifest3
-rw-r--r--sys-devel/omni/files/digest-omni-1.4a0
-rw-r--r--sys-devel/omni/omni-1.4a.ebuild72
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-devel/omni/ChangeLog b/sys-devel/omni/ChangeLog
new file mode 100644
index 000000000000..b2f88aea7858
--- /dev/null
+++ b/sys-devel/omni/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-devel/omni
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/ChangeLog,v 1.1 2003/06/03 13:03:24 tantive Exp $
+
+*omni-1.4a (03 Jun 2003)
+
+ 03 Jun 2003; Olivier Crete <tester@tester.ca> omni-1.4a.ebuild :
+ Added new ebuild for the Omni OpenMP Compiler
diff --git a/sys-devel/omni/Manifest b/sys-devel/omni/Manifest
new file mode 100644
index 000000000000..7b1b1583e75e
--- /dev/null
+++ b/sys-devel/omni/Manifest
@@ -0,0 +1,3 @@
+MD5 8049eb2b6498600b07f53ac67e27cced omni-1.4a.ebuild 1751
+MD5 645fec53eb06604ff0d80a86f89ba1ac ChangeLog 352
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-omni-1.4a 0
diff --git a/sys-devel/omni/files/digest-omni-1.4a b/sys-devel/omni/files/digest-omni-1.4a
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/omni/files/digest-omni-1.4a
diff --git a/sys-devel/omni/omni-1.4a.ebuild b/sys-devel/omni/omni-1.4a.ebuild
new file mode 100644
index 000000000000..e402415d8bc8
--- /dev/null
+++ b/sys-devel/omni/omni-1.4a.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/omni-1.4a.ebuild,v 1.1 2003/06/03 13:03:24 tantive Exp $
+
+DESCRIPTION="The Omni OpenMP Compiler"
+HOMEPAGE="http://phase.etl.go.jp/Omni/"
+LICENSE="Omni"
+SLOT="0"
+KEYWORDS="~x86"
+S=${WORKDIR}/Omni-${PV}
+A=Omni-${PV}.tar.gz
+
+IUSE="java doc"
+
+DEPEND="java? ( virtual/jdk
+ app-arch/zip )
+ sys-apps/sed"
+
+RDEPEND="java? ( virtual/jdk )"
+
+src_unpack() {
+
+ if [ ! -e ${DISTDIR}/${A} ] ; then
+ einfo "Due to license issues you have to download"
+ einfo "the appropriate Omni archive:"
+ einfo "http://phase.etl.go.jp/Omni/Omni-release.html"
+ einfo "Please get the file "${A}
+ einfo ""
+ einfo "The archive should be placed into ${DISTDIR}."
+
+ die "package archive not found"
+ fi
+
+ unpack ${A}
+
+
+}
+
+src_compile() {
+ local myconf
+
+ myconf=""
+
+ # There is no configure script for the doc
+ if [ ! `use doc` ] ; then
+ mv Makefile.in Makefile.in.orig
+ sed s/doc// Makefile.in.orig > Makefile.in
+ fi
+
+ use java && myconf="${myconf} --with-jvm=yes"
+ use java || myconf="${myconf} --with-jvm=no"
+
+ use doc && myconf="${myconf} --enable-installSample"
+
+ # scoredoc is just about the placement of the doc
+ econf ${myconf} --enable-gcc --disable-scoreDoc \
+ --with-thread=pthread || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+
+ # Put the doc in the right place
+ dodir /usr/share/doc/
+ use doc && mv ${D}usr/lib/openmp/doc ${D}usr/share/doc/${P}
+ use doc && mv ${D}usr/lib/openmp/examples ${D}usr/share/doc/${P}
+
+ dodoc README COPYRIGHT LICENSE
+}