summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/ct-ng/files/ct-ng-1.18.0-parallel-fix.patch')
-rw-r--r--sys-devel/ct-ng/files/ct-ng-1.18.0-parallel-fix.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/files/ct-ng-1.18.0-parallel-fix.patch b/sys-devel/ct-ng/files/ct-ng-1.18.0-parallel-fix.patch
new file mode 100644
index 000000000000..07dc76901d51
--- /dev/null
+++ b/sys-devel/ct-ng/files/ct-ng-1.18.0-parallel-fix.patch
@@ -0,0 +1,36 @@
+
+# HG changeset patch
+# User "Yann E. MORIN" <yann.morin.1998@free.fr>
+# Date 1361823571 -3600
+# Node ID f89f8e6f876679184acb66ea642e42c9e7cf2f44
+# Parent 716e7d90cac28ecb8f16cc2806426921f9893422
+Makefile: fix parrallel (-j) installs
+
+Currently, we would remove previously installed patches before
+installing the new ones. Unfortunately, that does not play well
+with heavily parallel installs.
+
+Now, we consider it is the responsibility of the user to first
+uninstall any previous version before installing a new one.
+
+Reported-by: Markos Chandras <markos.chandras@gmail.com>
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -r 716e7d90cac2 -r f89f8e6f8766 Makefile.in
+--- a/Makefile.in Tue Feb 19 13:07:09 2013 +0100
++++ b/Makefile.in Mon Feb 25 21:19:31 2013 +0100
+@@ -296,10 +296,9 @@
+
+ # If one is hacking crosstool-NG, the patch set might change between any two
+ # installations of the same VERSION, thus the patches must be removed prior
+-# to being installed. It is simpler to remove the whole lib/ directory, as it
+-# is the goal of the install-lib rule to install the lib/ directory...
+-install-lib: uninstall-lib \
+- $(DESTDIR)$(libdir) \
++# to being installed. It is the responsibility of the user to call uninstall
++# first, if (s)he deems it necessary
++install-lib: $(DESTDIR)$(libdir) \
+ install-lib-main \
+ install-lib-samples
+
+